Unable to Delete/Destroy Buried Foundation or Building Parts

Game mode: [ On-line ]
Type of issue: [ Admin ]
Server type: [ MP, both PvP and PvE ]
Region: [ America ]

As the title suggests I have had repeatable issues with destroying foundations, walls and building parts that are stuck inside or below the ground. The problem occurs when they are completely submerged. In ADMIN mode ghosting through the terrain does not help because once you enter the terrain Shift Delete no longer works. I have a player with one foundation just inside a wall natural game wall. It is offset and the snap points are preventing him from finishing his base.

You can see it but I cannot bring up the construction wheel because it is just behind the invisible barrier of natural structure. Additionally Shift Delete via an admin does not work. The natural barrier overlaps the foundation. Currently I am dealing with the aqueduct. When I fly into the aqueduct it does not matter. Admin commands assume I am targeting the aqueduct which cannot be interacted with. I could destroy all structure under a name but that is not a viable solution.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Find a natural structure like the Aqueduct while playing as a natural player.
  2. Place a foundation that clips slightly into the structure.
  3. Place another foundation that snaps even deeper into the aqueduct. If you can target the foundation that is further into the aqueduct then it is not far enough into the structure to create the bug.
  4. Remove the first.
  5. Create a small structure a few meters away in a perfectly intractable area.
  6. Enter Admin / ghost mode.
  7. Now destroy, the buried foundation without effecting the small structure in (step 5)

Again did my best to search the web for a viable answer on-line without answers that resolved the issue.

Can’t you destroy the foundation by interracting with it while in ghost mode?

try holding shift + ctrl and tapping the delete button twice, while the retisile is on the foundation.

this method will also demolish anything in the vicinity, so caution is advised.

The only fix I can think of and used it in the past is;

1a. Build correctly from the beginning.
1b. If you made a mistake, the only way to solve this problem what I know is making sure no other foundations are near so it will decay in 24/48hours. Not ideal, but there’s no other option on official servers.
2. Try as admin, I don’t have experience on PC but is there no option to ghost as admin so you can get
through the object, or an option in the console that makes you go through an object?

Is this what you are looking for? I find it possible to delete any structural component inside the gameworld. This assumes you are not on an official server and are admin.

Regards

jim

In reverse order.

@Jim1
I know how to enter Ghost mode, but thank you all the same. My problem is while in ghost mode I can fly into the Aqueduct however I can no longer interact with the foundation. There interaction wheel does not appear neither does Ctrl Delete. I dont know why but it has something to do with being literately inside of the Aqueduct which the foundation piece is.

@EXP88
I should have clarified on my Original Post. Admin Private Server. Another player built something they can not fix. Personally I would like to know how to resolve this as it is not the first time I have seen it. Players are good at getting building parts where they don’t belong. I had a player stick triangle foundations all the way up the mountaineer climbing challenge and there was two that I just could not interact with.

@droch-aon
Thank you I will give this a try and respond if it worked for this application. I never seen that combo before so It will be interesting to investigate.

1 Like

What about the delete-command that is typed into the command line while you have the target-reticle on the foundation?
I don’t know the exact syntax at the moment, but if you begin typing “del”, then the command line should show all available commands that begin with “del”.

@droch-aon This worked. I estimated a 10 block radius to the destruction. The bulk of his structure was fine and needed only minimal patch work. I was also able to destroy the buried foundations in the Mountaineering challenge by placing a block and using this burst effect.

TY
Gawain

1 Like

you are very welcome :slight_smile:

the console command is DestroyTarget, however this is extremely dangerous, and can delete the very terrain of the game itself, requiring a server restart to reload the missing terrain.

Using the hotkey double tap is much safer.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.