Unable to draw weapons or tools


#1

Game mode: [Online ]
Problem: |Bug]
Region: [North American]


I logged in this past weekend and found that everytime I tried to draw a weapon or tool, I’d auto sheath it. No matter what I’ve tried, it won’t fix itself. My friend plays on the same server and logged in to find he was having the exact same issue. I thought “eh I’ll give it a couple of days”. I logged in tonight and same exact issue is persisting.

I thought the stats and feats had been unlearned, but 1) that shouldn’t matter and 2) that’s not the case.

No idea how to fix this and obviously it makes the game completely unplayable.


Steps on how to reproduce issue:

  1. Try to draw your weapon. Nope.
  2. Try to draw your pick. Nope.
  3. Try to draw your ax. Nope.
  4. Log out frustrated.

#2

Same problem here…


#3

If this happens, a workaround is to do something else to get it out of the loop.
Press the BACKSPACE key a couple of times or initiate an Emote, this will normally bring you back to normal.

Logging on/off, restarting your game, reinstalling the game or verifying your files doesn’t fix it, I suspect its server side rather than client side.


#4

hade same issue, if i remember well, i remove my bracelt to correct it


#5

I’ve seen players try removing their bracelet and it not work for them. Just all a bit random really but the backspace or running an emote does fix it every time.


#6

Numerous treads on this problem plaging lot of player at this moment.

There are some workarounds that may work for some players, give it a try.

  • Play an emote, any emote
  • Hit twice the space bar
  • Use a 2-handed-weapon

You should now be able to use your weapons/tools again.


#7

Thank you all so much! Everybody on my server thought I was insane when I’d ask. Emote worked like a charm.


#8