Weapon not drawing Official Server #3741

Game mode: [Online]
Problem: [Bug]
Region: [New Asgarth]


[Drawing a weapon or tool just results in putting the weapon or tool away. The animation of the weapon being drawn fires and the. The weapon is immediately put away. Trying to break the loop is not working, laid down a few walls tried to do an emote (wouldn’t fire either) did not result in the desired effect.]


Steps on how to reproduce issue:

  1. Draw a weapon
    2.weapon goes away

By region, I believe they mean in real life, like North America, Asia, etc

If you have it available, do you happen to have a two handed weapon? Try equipping one of those.

Thanks! North America.

Usually when they have that “equipment” bug, a usually fix is to equip the two handed then switch back to see if it works.

If at all possible, linking a video of the problem in your posts helps the developers and the team like @Ignasis help communicate the issues to the rest of the team so they know the issue and see it, so it can be addressed.

1 Like

I have noticed that whatever I place in the 10 o’clock position of my wheel does not get drawn on occasion. I have to pull a two handed weapon, and then pull that position. It has happened with the repair hammer, axe, sword, and chain.

Two handed weapon solved the loop! Thank you!

1 Like

Hey @DjNilla

Welcome to our community and apologies for this issue, our team is aware of it and they’re looking into it.
Thanks for your feedback.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.