Unable to Equip Tools/Weapons

Game mode: Online
Problem: Bug
Region: Americas

Unable to equip tools or weapons. Every time I attempt to it begins the equip animation and then stops. I have tried removing all my tools/weapons from my Radial Quickbar and rearrange them and it didn’t work. I also tried dying by removing bracelet and allowing NPC to kill me. My situation is a little more unique than normal. I was fighting an enemy with a sword and sheild and then made a mistake and unequiped my sword mid fight and died right away. So I don’t believe this is an issue where there is an invisible weapon. I am unable to play this character because of this.

Steps on how to reproduce issue:

  1. Fight an enemy with weapon in hand.
  2. While fighting them un-equip the weapon so you are unarmed.
  3. die.
1 Like

Hey there @jab3496

Welcome to our community and apologies for this frustrating issue. Our team is aware of it and they’re looking into it. On the meanwhile, other players have reported that triggering an emote when you’re experiencing this problem seems to get rid of it.
Thanks for your feedback.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.