Unable to play online on any server

Game mode: Online
Problem: Crash | Bug
Region: Europe / Germany

For the last couple of days i have had a problem with logging into online servers for conan exiles (doesn’t matter if i tried official or private). At first I just had to try to log in a lot; after a significant number of times it usually worked, although i subsequently had a bit of lag when playing (which wasn’t a huge problem though). But now for the last two or three days i am completely unable to log into any online server. After the loading screen progresses just a little bit i always get a notification along the lines of “connection to the host has been lost”.

A few more details:
-Any other online game works just fine and ive checked my connection multiple times and it works as usual.
-A friend of mine who lives just a few miles away has the exact same problem ( the region is europe/germany/southern bavaria)

I would be grateful if somebody could help me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.