Weapon constantly unequipping

Okay, here’s what’s going on. If I have weapon equipped it will unequip UNLESS I am actively swinging it. It seems to happen every 2-3 seconds, so if I am constantly swinging, it will not do anything unless I actually get one of these unequip ticks between swings. If I equip a weapon and press escape to bring up the menu, it still happens in the background, so it’s not system level. It only began about 3-4 days ago. I have removed all the recently added mods, and still nothing. I had found someone with a similar problem who found it was due to a shoulder item being worn from GrimProductions, and I had one. Tried removing ALL Grim items. Still happening. Here’s my current mod list:


Immersive Armor

High Heels System

Navi’s Extended Levelling Mod


Devious Desires


Barbarian Baber

Female New Faces

RA: Fantasy Extension

RA: Character Customisation

I have tried making sure the files of the game are not corrupted, and no dice there. Any ideas?

Test by removing Devious Desires.

Well that solved it! Created some other weird issues (cloth and hair sim seems to be broken now) but thank you! One problem at a time! :smiley:

I don’t use the mod, I have just seen people reporting the same issue while using it. Check their discord, maybe there is other solution than removing the mod.

Many thanks, now I can fight again!

Seems it’s actually partially Devious Desires. I removed it, and tried adding it back, did a suggestion that was in their discord: removed all my armor, then re-wore it. Stopped the bug.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.