Well.. no clues on what to do? (Talents blocked inside)

Ok, I just bought the game on Ps4 yesterday.
Dowloaded all possible patches (version 1.05 latest?) but the game feels not working so good (I’m an offline palyer in a single campaign).
I reached level 22 (barbaric mode, no modifications) but still I can’t assign many talent’s points: I have almost well 57 un-assigned and I can’t “use this” points (used 22).
Now I have no idea on the level cap or the progression of the story but how can it be that O have all these points and still can’t build lesser stuff?
I just managed to create basic grounds and light leather armor…
Is it me doing something wrong or else?
Should I meet some NPC first?
I honeslty can’t find anyone to talk to beside the guy under “the Sentinels” but… I roamed a lot: from ruins of Xel ha, to dagon’s embrace (sorry if I miss-pronounce the names, Playing in italian) or bucaneers bay to the passage or the great dam…
I didn’t find any friendly town (if any exists) or helping NPC.
How can I “unlock this already unloicked” points?

Thanks for helping


The feats do go by your level :slight_smile:

have you tried highlighting the row and then pulling R2 to assign or ‘spend’ them? about the NPCs,nope no story line or quests. its survival :wink::grinning: as for the stats, a free tip go all vitality , or at least till self health regeneration. trust me you want it

I understand there’s no questline or else, but the game is really “cloudy” by itself: without a real tutorial you just go “random” and so I really get confused about many things.
Skinning animals with a knife (the game asks me to do it), where do I find a knife?
I’m scavenging animals and humans by pickaxe or woodaxe but in over 30 hours of playing (2 days I have it) no knife anywhere,
Or… Gone into dungeons with undeads and weird draconic humanoid skeleton and found “blackholed entrances”, inner caves that are really not entrances but have this black wall of nothingness that prevents you from entering. Is it a glitch? Is something I should discover after something else?
For example this “slaves” things what is it?
How am I supposed to enslave anyone if every (and I mean every) one that I encounter has to be killed?
The game lacks (a lot) in giving you instructions: I understand that you’re free to play as you want (and it’s ok)
but you never know if something is bugging (game bugs a lot) or it is you doing something wrong.
I just don’t like this “go on your own” that puts the gaming in a “randomic act of killing”, especially when you play hours and hours gathering resources, exploring the area to find anyone to trade with or else, you die and maybe your corpse gets “lost” and you “bestemmi la madonna” (Italian cursing) for having lost bunch of hours “for nothing”.
Anyway thanks for the replies, today I’ll try to restart again and see what happens.

I had the same problem when I started the game the first time. I was just walking around and no idea what to do next. But thats with most survival games unfortunately. Just google it.
As for getting Thralls “Slaves” you get them by building a Wheels of Pain and Truncheon and Fiber bindings. You need to knock out a human npc with a Truncheon and when they are knocked out use Fiber bindings and drag them to Wheels of Pain.
Just google alot in the beginning and learn about it.

1 Like

Usually I don’t like to google to know a game: I like to have it on my own, currently I’m at 50th level and still haven’t found a way to obtain leather (nor I can find it around) to make the club to knock down people… and I still have a LOT of unused talents points! (Killing giant animals and enemies with stone weapons LOL… I’m a patient guy)
Somthing is wrong with all of this:
I’m “overlevelling” the game without progressing: I unlocked chapters hint that I presume I should unlock forward in the game… but still had no chance to “skin an animal with a knife”.
So I’m enjoying it, but game is badly balanced. All for a stupid knife and leathers I can’t obtain! :slight_smile:

Oh…and by the way: anyone knows how to cure corruption? I know I should find a dancer but as I said: no friendly npcs around.
Or should I enslave a dancer and make him “dance to cure me”? (same problme as before: can’t find leather, can’t obtain a knife, can’t craft club to knock down, can’t make slaves, yaddayaddayadda).
Basically I’ll remain a true “neandhertalian” 'till the end of game ^^

Tannery? How to have it?
I understand all the issues of slavery and using slaves to get their services but as you see I’m stuck just in the beginning: obtaining a club to knock’em down.
Honestly I have no tannery (conceria for me italian) anywhere in my menù or artisan tables. I already got bark and stuff by using “wrong” tools but I jsut miss this tannery.
Where do I get it?

I do not have the recipe to make it.
I already checked around (googling for desperation) but I do not have the recipe.
Ii doesn’t appear anywhere in my menues, starting to think it’s bugged as dumb.
Basically I have all the ingredients but I do not have the button to make it!

I’m seeing a lot of videos on you tube (Pc players I’m a ps4 one) and they simply have the tannery button… I don’t have it.
I already build temple for the gods, houses, artisan’s table, armor’s table… I know how does it work.
But I just can’t make any tannery because I do not have the option button to do it.


JEEZUS I found it!!

Damn put a freaking indication to move around artisan menu (R1- L1), damn guys…
As already said, this game terribly lacks of basic informations: I had no indication that I could scroll in the talents menù with those buttons, damnit.

Ok problem auto-solved.
Thanks all for the patience.

Oh well, not entirely solved to be honest: I made the club to knock humans down but…
it still kills them!
Am Im I wrong again?

I have it, but when I gave the last hit they explode in a pool of blood.
I tried also to hit them ONLY with one light hit per time but no working.
I created also other tools (like iron knife) but not all appears on the creation menù: it has to be said that this Ps4 edition has a totally messed menù with no organization and all things randomly mixed in the page, something has to be done for real.

Devs have said there is currently a bug with the trunchen killing instead of just knocking out thralls on ps4

That is not the only bug present ^^
I can’t reach many talents I’ve unlocked because they do not appear in the list, even the page with “search” has no sense at all on PS4 because , well… you can’t type anything!
There are a plenty of things that needs to be fixed…
But instead I love the atmosphere of the game, many areas are really intriguing.