Xbox 1, Conan's Atlantean Sword No Longer Able to Craft

Game mode: [ All game Modes]
Type of issue: [ Other ]
Server type: [ All Type ]
Region: [ North America]
Hardware: [ Xbox ]


Bug Description:

After log into the game right after the big launch of the new Island of Siptah, I played like I normally on official. I decided I have not crafted this sword for a while and I started looking for it. I know it used to be in my inventory to craft, but the Atlantean Sword was not there anymore. I went throw all of the crafting tables, and I am not seeing it anyway. I feel like this is a bug in the game that should be looked at. I wonder if there is anyone else who noticed that they didn’t have it anymore on Xbox either. To test this out, I went to other official maps in the standard game, and I have characters in pvp pve and pve-conflict all maxed to lvl 60 for that game. I went back to solo game to try it there and nothing seemed to lead me to where I could see the sword missing. I tried spawning in the sword and I would get an error code, failed spawning 1 X Game Item 8000. I still have my day 1 edition of the game with the code I used to allow me to have access to the sword.

Has anyone else had this issue come up after the new map was released?

Steps to Reproduce:

Start up the game, go into any game mode, on any server, play in any type of setting, pvp, pve, pve-conflict, and check to see if you can make the Conan’s Atlantean Sword from the Blacksmith, Improve Blacksmiths like it was meant to be crafted.

1 Like

The Atlantean sword has been relocated from personal inventory to the assortment of blacksmith benches.

1 Like

Thanks for the help, but I think you missed the point. The sword is no longer available for me to craft. It isn’t in any of the blacksmith benches for me either.

Hello @Stragerd, can you please verify if you’re able to spawn the sword for yourself in the singleplayer mode through the Admin panel?

Go to manage games and addons for Conan Exiles on your xbox and double check that the Atlantean sword is listed as installed. Also, are you launching the game from disc or Gamepass? The xbox can sometimes not recognise the licence for a particular dlc is installed as well.

I’m also missing this sword - it’s not in the blacksmith’s bench.

I did attempt to try and load the sword in singleplayer mode. It gave an error when I tried to spawn it in.

Thank you for that little information Lucidique. It seems like that was the cause for the mysterious disappearance for the sword. I was able to find it in the blacksmith after checking on the Manage games and looking through the DLC’s. I had to reinstall it for whatever reason.

Thanks again for your help with this.

1 Like

All of my DLC was installed - I don’t see the sword in the blacksmith’s menu. This game has been so aggravating with its hundreds of problems, I almost don’t care anymore…

So your xbox may not recognise the Atlantean Sword. Reinstall that particular dlc only (10mb), restart the game once it’s redownloaded and check your smithy bench again. It’s listed in alphabetical order.

I reinstalled the game and addons, since there’s no option to selectively uninstall addons and, of course, there’s no Conan’s Atlantean Sword. Wasn’t this supposed to be a perk for those who bought the game on Day 1?

It was a dlc code that came with day 1 edition. If you had the code and redeemed it you’d be able to craft it in game (originally found in player crafting inventory but later moved to the various blacksmithing benches).

My point was that if this was to be a perk, those of us who had the dlc file and installed it should be able to craft the sword as easily as we did before the update, only in a different location.