Atlantean Sword not Showing Up

Game mode: [Online | Singleplayer]
Problem: [Misc]
Region: [America]


Not sure if this is the place for it and Ive tried looking around for any further clarification but could find none. Like most new players, I got Conan Exiles through the PS+ promotion recently and began buying DLC for the game. I noted the existence of the Atlantean Sword and looked around for a method to obtain it so I ended up buying an unused PSN code. After confirming it worked through the PSN store, the image of the sword and the words “successfully redeemed Atlantean Sword” on the screen, I cannot find it. I see no download available (which I didn’t need for the Age of Steel I noted), but I do see in my history that I purchased/redeemed the code and it exists in my account. My friend has a private server, I used admin commands and nothing doing about spawning it in. Giving me the similar error code you’d get when trying to do that with DLC you don’t own. I went to a public server, single player, no sign of it anywhere. Not in my craft menu or the blacksmith bench. If the code was expired, it would have said so, and I wouldn’t see a successful redemption on my end so I can only assume its the game? I’ve triple checked the Conan Exiles page in store, under the file where DLC and add-ons are, and re-confirmed the very valid code processed and have a digital receipt saying so. Is there any answers for why Im not seeing it? Thanks


Steps on how to reproduce issue:

  1. Have digital edition of Conan Exiles on PSN
  2. Redeemed physical code
  3. PSN says you’re good
  4. Conan Exiles says you don’t have it and it doesn’t exist.

ON friends co-op, it may not be possible, as you are playing in his sandbox.
For official, what level are you? you still have to get to level 10 to craft 2h to unlock the sword. Do not remember if it shows up in the all recipe page or not in red before that. I don’t believe it does. It will be in your hand crafted recipe menu if it is not bugged.

Im level 24 in this official server I just started playing recently, maxed out on another server, obviously insta maxed myself in the private server. Im sure that’s not the issue. This seems more like a funcom thing to bring to their attention.

1 Like

To my knowledge the code only came with the hard copy of the game same as conan armor.

See also https://conanexiles.gamepedia.com/Conan_Exiles#Game_Pre-orders

Those swords are made in your crafting menu not on a blacksmiths bench.

1 Like

I know. I bought the code. An unused code.

There is nothing in that section which says the codes provided would expire. And I already mentioned the code was accepted as valid when I redeemed it.

Realize that, just checked to be sure anyway so I wasn’t wasting anyone’s time.

And they were in the package with the disk. It has been a year since I redeemed mine. You likely need to use it with the disk not a download as it was meant as a preorder bonus. Sorry.

I haven’t seen a case where that is how the codes work and no information suggesting so. Im just looking for an official response.

@Elastas if the code was valid which it sounds like it was from your description then it should be there.

One thing I want to ask is are you sure the region for your code and the region for your game match?

I have the US and UK disc version of the game. I purchase all the DLC from the US store. When I play on the UK disc I don’t have access to any of the DLC I purchased on the US store.

I’m sure you will get an official response at some point but our questions and trouble shooting really does help them narrow down the issue.

2 Likes

Yes it was sold specifically as a US version, only shipping or emailed to people in the US. I’d covered my bases on the specifics before I dedicated some spare change for it. I get Im coming off irritated because I am but its not at any of those who have cared enough to respond which I appreciate. Just waiting on some help and occasionally logging in and out on the game to see if this item is ever going to show up.

1 Like

@Ignasis could you help this person or merge him to a better thread. Thanks.

Hey @Elastas, welcome to our community.

Could you do a quick test for us to see if there’s something wrong with your licenses?
Go into single player mode, make yourself admin, then open the admin panel. Under gear, search for the Atlantean sword and try to spawn it.

@Ignasis does this mean I could buy a code for conan armour that I didn’t get at release?

Some players reported they got retail copies of the Day One edition just for the DLC code. So it’s certainly possible, if people can still get their hands on one of them.

1 Like

Thank you for the info.


Could possibly help.

PS: @AndyB uwu this is nifty (thank discourse)

2 Likes

Hi there. I already tried admin powers to spawn in items on a private server but I went ahead and started a new game on single player to see if maybe there was a weird data thing preventing it from working before. It won’t spawn in the item like before acting like I don’t own the DLC. I get the FAILED SPAWNING 1 X GAME ITEM 8000 or 8011 depending on which one I click. If you’d like I could DM you a screenshot of my purchase history on the store for the sword if this needs to be taken further than it already has.