Xbox one X - Crash to desktop accessing online game

Game mode: Online
Problem: Crash
Region: EU/UK

Since latest Hot fix I am now crashing to desktop whenever I attempt to join and online server. I have had intermittent success but since yesterday and today I am unable to login with a crash xbox desktop with 10-20 seconds of logging in.

What I have done so far .

  1. rebooted xbox - crash to desktop
  2. cleared cache on xbox - crash to desktop
  3. reinstalled game - crash to desktop
  4. tried connecting to single player first - crash to desktop

Then today after too many login fails I rebooted my router (Netgear nighthawk R8000) and got in first time. Now this might just be a coincidence as I am having no other network issues on the xbox (other games are fine) and all my other connections in the house are also fine.

I will test and see if this was just a one off success.

*********** Update *************

It was a one off success and once the game was relaunched it fell back to the good old crash to desktop.

Further testing

  1. Switch from wired to wifi connection. - crash to desktop
  2. re-tries launching single player first - crash to desktop

Further observations. Conan is the only game I have that drops my audio in a group chat when I connect to a Conan server. no other xbox games do this. This in itself makes think this is a network connection management issue somewhere in the code. That said I am no developer.

Happy to supply further diagnostics if required.

In summary I am unable to connect to the online game since the last February fix.

I have now checked my router logs and there are no errors being reporter when the game crashes to desktop.

Steps on how to reproduce issue:

  1. See above narrative

When you launch single player, you are pressing X (play offline) and not A, correct?

Have you tried running a ping test or anything on your home computer? Sounds similar to issues I had in a different game at one point which ended up being due to packet loss issues.

Are you having trouble with any other online games?

Also, is the game installed on an internal or external drive?

Hi @Manty64, to add to the above, could you please check out what is your current NAT type, and also run a multiplayer connection test?

Can you confirm if UPnP is enabled? Does disabling it change the outcome?

If possible, make sure that all the ports required are being forwarded as well.

Currently away from Xbox for 36 hours so here are the answers I can offer immediately.

NAT : Open

UPnP: enabled (can’t test turning off at this stage, but don’t expect any difference to be honest)

Multiplayer test: all fine. No other multiplayer game issues.

Ports: I haven’t opened any additional ports to enable other games. But I can check this in the next day or so.

Hmmm, I think I have been using A to launch the single player game. I will have to test when back home in 36 hours or so.

Thanks for the clarification of using “X” to launch an offline game … this now allows me to login and play

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.