3514 not loading AGAIN

Game mode: [Online | Singleplayer]
Problem: [Crash | Bug | Performance | Misc]
Region: [Here]


I’ve let you know about this before. Later in the afternoon we can’t get loaded. It seems like it was actually fixed at one point but it’s doing it again. Central time 7:45 pm on 10/19/20. I’ve actually lost a base due to this.


Steps on how to reproduce issue:

  1. Choose 3514
  2. Watch loading screen
  3. Wish death to gportal
  4. Play Elder Scrolls instead
1 Like

Same here but I keep getting ignored

1 Like

They already have our money

@PMSPrincessBlues @PriestessAthena Does not seem like any Funcom admin has been in Forum since last week.

Looks like they just got on perhaps you can get some answers.

No. I was getting a little sassy because I’ve posted so many times and they said it’s most likely on my end, but so so many people are having this problem. And now I can’t get a response at all.

1 Like

Who do I contact for a refund for the game and DLC that I paid for?

Hi @PMSPrincessBlues, we’ve reached out to G-Portal regarding this specific server.

We’re unable to handle refunds, you’ll need to reach out to the store you’ve purchased the title from.

1 Like

Still not resolved. I’m not letting this thread close automatically as if it’s fixed. I know they can fix it because they’ve done it before.

Still happening and it’s worse than ever

2 Likes

Sorry to hear that. Keep complaining!

2 Likes

It’s been happening for months luckily I started on a different server. I try to log into this server but unless it’s early morning I’m not allowed. I can log into others immediately but not 3514. When log in is successful I often see exiles on player list then gone after a few minutes. I imagine stuck on loading screen. This is a problem on 3515, and others according to posts that have been made. I see bases decaying when I log on, that’s not fair to the Conan communiity. Players have spent a lot of time enjoying this game and your not looking into the matter of this inconvenience. I’ve looted 5 bases in the last 5 days. Not proud but those bases would still be there without your incompetence. It’s a server issue not ours. I dare you, take a console home with you and play by our rules you’ll understand then.

1 Like

Still not able to load and it’s early in the day.

1 Like

I’m going to decay!

3514? Try All ther servers from Latin America yesterday 05/11/2020 (ping is 9999 ms)
It’s been like this for 4 consecutive days, we know it’s an intentionally DDOS and funcom did nothing until the moment!
Tons of messages already sent, none replied!

Think twice before buying siptah dlc.
The only way to make them fix this kind of things is not buying from them!
Glitches, undermeshes, God thralls (hit kill), crashed servers and stuff!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.