A Modest Proposal Tier 3/4


#1

So, I’m trying to get Luiseach through storyline, and unfortunately it seems the EMP Grenade is not working to disable the turret?

I’ve tried from multiple angles, no dice.

She’s whistling very strangely through all those bullet holes… is this a known bug, and if so, what the heck do I do, because I can’t progress with that thing mowing me down.


#2

Update:

Another player was having the same issue, but we ended up sort of goosing through it playing tag with aggro of the turret and setting charges.

So, phew! But also this could be a real pain for folks. Heads up!!!


#3

iirc you can cast it from farther away than it actually works and then you lose your item for nothing but it’s been a bit since I tried that mission.


#4

I also assumed bug on first attempt back in tsw, and submitted petition myself before persistence won out.
Just reran it now without issue.

By using the cover of the rock wall to get to a close position where to bring up the grenades reticle on target, before moving to a better angle to throw.