"Bustin'" is broken

This is literally the only main mission in SWL right now that I have not completed. I’ve reported this mission numerous times for nearly two years now, and have yet to hear from anyone about it. So, this is my last resort; complaining on the forum boards.

The very first time I took this mission, I had to pause it because it took longer than I thought it would to complete, and I had a cabal event to attend. No big deal, missions are paused all the time. Ever since I paused this mission, it shows I’m at tier 3/4, go to next area. I go to the last area, it shows I’m 4/4 when I get there, and… Nothing. When I unpause the mission, the ghost-catching item next to Kurt’s tank doesn’t appear, which is probably a very big reason I can’t complete this mission.

No, it’s not in my mission inventory.

No, having friends share the mission and them completing it does not complete it for me.

Fun fact: If I’m in a team with my friends and they go to Kurt to get the mission, Kurt refuses to appear to them. This has happened a few times. I’ve had to drop team and LEAVE THE ZONE ENTIRELY for Kurt to appear and for them to take the mission.

I’ve tried sharing my mission, they’ve tried sharing theirs. We’ve tried every combination under the sun to get this mission done, and its all failed.

I didn’t really care a whole lot until I got a Peculiar Box. Now this one dumb mission is standing between me and doing the fight.

So, can I get some help on this, please?

You have opened a petition, and gone back to make sure the petition is still open? Because on a mission broken like this, it sounds like it would need a GM to unstick something or give you the mission item. However saying you have reported it multiple times and never heard back makes it sound like the petition did not get submitted, if you intended to submit one. It is easy to miss that it makes you confirm the petition twice during the submission process, but if you go to open a petition when you have an open one, it should take you to your open petition instead.

3/4 shouldn’t be going to the last area. That already should be 4/4.
Did you check the second area, near the waterfront?
I feel like one mission trigger got broken (Something that hapened to me with venice sinking) and now it has issues getting into the normal modus operanti again needed the GMs to go into the code and hardreset the mission.

P.S.:Not having the mission item in the inventory is normal. Since it doesn’t give you a mission item but fakes it, kinda. Some missions do that but most have roer missioon items.