Bustin mission bugged for me

well… I have an issue regarding the " bustin" mission in kaidan, and I didn’t have an answer so far. So I tried to do the bustin mission in kaidan but at tier 4 I kept dying against the onry, i changed the mission and it was “paused”. The thing is that the mission items at that time was limited to 3 so i deleted the mission item. Now that i want to finish it, the mission is at tier 4 but i don’t have the item to place at the alley. i cant restart it and i cant pick up the item lying in a box next to the orochi tank.

The best to do is a /petition in game and get a hold of a GM. They can give you the item back.

Alternatively might work to get another player to do the mission with you. The placement of the item is shared if i remember right.

1 Like

I did both, the petition is not being answered and I did the mission with another one but it didn’t work :frowning:

As CS isnt open 24/7 they might miss you, in which case they should leave a reply to your petition, and you have to reply if its still an issue. They are usually fairly fast to answer, but it depend on how many petitions they have.

I’ve never had to wait more than a couple of hours for a response to a petition.

But: You wouldn’t be the first person to think they’ve submitted a petition (or ticket) when they’ve actually been a step short. After you type in your petition text and submit it, you’re taken to a FAQ-type screen with potential answers based on keywords in your petition. At that point, your petition hasn’t been submitted yet. You have to hit the submit button again to actually send it.

When in doubt, check the help window to see that your petition text is there. Any responses from customer service will also be there if they didn’t manage to contact you while you were in-game.

You should be aware this is an issue a GM can probably even fix while you’re offline.

Clearly explain in your /petition the problem is you don’t have the quest item. A GM attending the ticket while you’re offline will probably be able to simply add the item to your inventory, thus enabling you to continue the mission when you next log in.

ill try that! thanks!!

Just as a note for other players, the mission “Bustin” in Kaidan is one of the few you should never, ever pause. The Item you pickup is just a flag (no actual item appears in mission items bag). Almost every person I’ve interacted with that paused it or left zone to do a dungeon or something, had it break.

Also note that doing as a group, only one person needs to place the device but everyone in the group needs to pick it up after each defense.

we tried as a group, when the other player duck to place the device, i don’t see it… just the sparks… and when its done there is nothing to pick up… for me at least, a gm reached after my petition but we couldn’t agree to solve the issue yet

oh yes, I know, once it’s broke, it’s broke and only a GM can help you get that flag back. My info was more for other players.

I’ve tried to help a few players that way and it doesn’t work.