Additional dialogues (blue speech bubble icon) with NPC's/characters bugged


#1

NPC dialogues seem to be bugged for me, where they often are no longer clickable after selecting a dialogue line. It’s not just the already played dialogue line that becomes unclickable, but all of them, even those I never clicked before. They’re just greyed out and can no longer be used until I relog, then the issue comes back after talking to any character. It’s as if the dialogue system doesn’t recognize that the line is over and the dialogue just remains in the “currently playing a dialogue line”-state, where the lines are greyed out, but just remains in that state.

Is this a common, known issue? Is there a fix for it?

Since I’m pretty much playing the game mainly for the story and background lore, just ignoring these additional dialogues is not an option for me.

I just installed the game today, no mods or anything used. Only thing I did was converting my SWL account from a Steam-Account to a regular, non-steam account on the account page.

My system is as follows, in case that might be of relevance:
I5-6600k, at stock 3,5ghz
NVidia RTX 2080
8GB of RAM
Windows 10 x64

Any help would be appreciated.


#2

You have to relog, just walking a little ways away and back doesn’t fix it? Without seeing what you are doing, it sounds like what might happen if the cursor isn’t pointing at the NPC correctly if the dialogue option stays small and grayed out. Does this happen to NPCs that have missions as well as ones that do not (since it may be a bit easier to tell if it is showing the right size icons that way)?

Also it sounds like this happens to you even after walking around, but I know that logging in right next to a character that gives missions can cause issues, not sure if it can also cause dialogue selection issues.


#3

Thanks for the fast reply! :slight_smile:

Walking away doesn’t fix it, no. And I also did not log in near the affected NPC’s. It also appears to be quite random in occurence, I talked just fine to the Sheriff when arriving in Kingsmouth for example, just for the dialogue system to fail on me when talking to the guy outside near the car wrecks, working on a bomb or something (forgot his name, a NPC with the blue dialog bubble available though. Same happened in the intro earlier in the game, with the Illuminati tutorial in the laundry salon.

As I already said, it feels as if the dialogue is just getting stuck in the “you cant select another dialogue line right now since one is already playing currently”-state.

And I’m also quite sure that I pointed at the NPC correctly, since it sometimes even happens when I dont move at all after clicking a dialogue line.


#4

I had another thought, can’t test it atm since I’m at work, but could this be related to high fps? Considering tons of “older” games start bugging out with fps being too high? I’m playing the game with a RTX2080 at 1080p (complete overkill) since the UI becomes unreadably small at 4k so the fps sometimes reaches well beyond the 144fps mark depending on the environment/viewing angle.


#5

Hello eZudo, sorry to hear of the trouble. Please check and see if /reloadui brings the dialogue options back. We can troubleshoot further based on whether that works or not.


#6

Following some steps I found on reddit (seemingly the exact same issue), the dialogues appear to be working again. At least so far (played around 1-2 hours, the npc’s I spoke to worked fine. Unfortunately I cannot post a link in my answer, but the solution comes up when you google “Secret World Legends Dialogue bug”, in case anyone runs into the same issue.

If that lasts, I’m happy :slight_smile:
If not, I’ll be back :stuck_out_tongue:

Thanks everyone


#7

So, the issue still persists apparently, happened again today, although much rarer now.

/reloadui does indeed work to bring dialogue options back, although they start from the first line again. Still, that’s a pretty tolerable solution for now, when the issue comes up. Still, I’d love if we could keep troubleshooting this so the issue gets resolved alltogether :slight_smile: