:news: Age of War: Chapter 2 - Known Issues (Updated)

@Pliskin Hi team. Forgive my hasty grizzel earlier; from my own personal play experiences this has definately been one of the smoother patches to hit the Playatation version thus far. And I am thoroughly enjoying what I have played of the new content thus far. The new loot is fun and has me enthralled, the multidirectional combat is more intuitive and adds challenge, and the battle pass is awesome. Oh and the shrunken heads…love them! :smiling_imp: :drop_of_blood: And I LOVE the communication here in this thread and the swift decisive action on the Encounters too peoples.

My Feedback:

Thrall Pot & Feeder Box

Please, PLEASE team fix the Thrall Pot and the pet Feeder Box for all platforms. This is directly relative to Chapter 2 when we consider that we are participating in a purge revamp. Players and clans do not want to have to manually place food in the inventories of dozens of thralls and pets, or even more frustrating and stressful: potentially do so in between waves too if the followers exhaust their supply. I plead with you all to make this an important point on the ‘to fix’ list.


Why remove vendors for no reason what so ever. When so much is bugged why focus on removing something good in the game! I undersrand removing the weapon vendors but the tool and supply material is totally fine! :sob::sob:


What is purpose for obulus now?


When you get a chance, take a look at how followers work. I am spec’d for war party to level up thralls, but they don’t seem to want to follow. They wait until you are far enough away to teleport to you, but will not run to you and most likely not be near enough to enemies to engage them in a timely manner. Also, cannot get both of them to stop following, when telling them to stop following, one will stop, but the second one will throw up the info text: “thrall not following” quickly followed by “thrall is following”.

Edit: on PSN if that matters

Followers don’t move anymore, while on follow. They sit there like stumps and ocasionally teleport to my location. Cannot place thralls on any type of surface, while the message “must be placed on walkable floor” is shown. (official PvE-Conflict server)

The unsheathe animations sometimes(after a fight) stops working, weapon teleports directly on the back while empty hands gestures are happening.


Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 6738]
LoadPackageAsync failed to begin to load a package BP_Event_SiptahStormspawns_ELW because the supplied package name was neither a valid long package name nor a filename of a map within a content folder: ‘’


Any thing about PvEC official servers for ps? Pvp and PvE sem to have no issues but PvEC keeps lagging assuming you can log in

Everything is great with javelins. They’ve been neglected and nerfed for a long time, and now you’ve finally given them their due. No need to nerf them again, please! ((I don’t mean Riptide)


Do you guys know of the severe Lag/and or desync affecting playstation where You can be very far away from a player and or NPC and they’ll be able to kill you still? And them walking in one direction then teleporting around constantly I’m not sure if this is for other consoles too


I spent hours trying to get into the game because of the infinite loading screen issue, but when I finally did, I see that it is unplayable due to the lag of up to 15 seconds. In this aspect, it would help to enable an official PVE-C server for LATAM region (Ps4/Ps5), since there is currently not a single one of the Exile map in my region. At least one please!

1 Like

Also the delayed health bars and stamina bar not updating for a good amount of time after taking damage or using stamina


If it’s intended why do the patch notes say you can now view all the items vendors have for sale instead of just the current one?


So now that the vendors at Mek-Kamoses have vacated, what is the use for blood crystals other than upgrading/creating golem parts? That honestly just destroyed my purpose of farming blood Crystal like a maniac this past rollback event of 4x for pve-c. Why not leave the vendors for pve and pve-c servers and remove them on pvp since that’s where there were more complaints. Just wasted hours of my time.


All AI (thrall and enemy alike) are having desync issues. Definitely something that needs attention, perhaps a network optimization. It’s as if not enough data is being transferred to the clients in the received packets. I’m not sure whether it is simultaneous purges that are taking up too much of the allotted space or perhaps the events you mentions, but it seems to be occurring on most, if not every platform. My private server is far better than officials are, but still suffers majorly from this lag issue. It is very difficult to play with enemies rubber-banding and teleporting everywhere, getting hit when it seems like no one is around.

Once the performance issue is addressed, I can safely say this is going to be an AMAZING chapter in the Age of War saga. :star_struck: Hopefully this was already on your list and just wasn’t very clear. :wink:

Thanks for your update today Funcom, it was much appreciated! :heart_eyes:


Is it still intended for armor recipe from the Delving Bench to no longer give the Epic version of the recipe on Isle of Siptah?

Before the patch, tried delving Cimmerian armor. It gave me the recipe, but on either the Improved Armorer’s Bench or Garrison Armorer’s Bench, no Epic version, just the regular version on the Improved Bench.

After the patch, tried delving Darfari armor. It gave me the recipe, but same deal. Normal cannibal’s on the Improved Bench, no epic on either the Improved or Garrison Armorer’s Bench


Since Chapter 2 update our PVE server has been badly affected with invisible NPCs, lagging, followers not responding and death caused by opponents 10 feet away from you. The game is very unplayable on this Nitrado server.


Same here, ever since the update there has been many issues:

  • NPCs attacking when not anywhere near.
  • NPCs spawning as I get right Infront of them.
  • Thralls not following/running on the spot and jumping to me.
  • Thralls not responding to being attacked.
  • Long load times of user made camps.
  • Damage not showing on the target.
  • Stamina running out but not recharging, just jumping to full almost a minute later.
  • Rubber banding is worse

I hope the Devs acknowledge this issue as many players have had this, yet it’s not been added to the Known Issues


Black Knight armor (epic) is still bugged on consoles at the least. We are unable to craft this armor on campaign or improved benches. Unless I am wrong, there is supposed to be an epic version of this. Clarification on this topic would be most helpful.

Don’t know if it has been pointed put but loot specific storage boxes (skinning, ores, wood, etc.) are still being left in the open position animation when used until accessed again.


We have a house with gently sloping hills and flat meadows all around us. Also, we don’t have any close neighbors to get in the way. We get the following error when starting a purge: “No reachable location for the purge to setup their basecamp” With such an ideal location for a purge to set up, this seems like a rediculous error message. Any ideas on what is causing this issue?

Additional note, on PCs the Thrall Pots and Feeder Boxes haven’t worked in years. Some thralls take all the food while others go hungry. Animals will do the same but its worse because they will take foods they won’t even eat. I agree with the PLEASE, PLEASE, PLEASE by Croms_Faithful because it takes too much time to feed the thralls and animals.