Altar Bug and Body Bug

Game mode: Online official 1727
Type of issue: BUGs
Server type: PvE
Region: North America

Two Bugs:

  1. After building tow altars recently (Mithra and Yog) I noticed there was no recipe for the next level altars after building up some religious medallions in each still no recipe appeariong for lvl 2 altars. Is this a bug or do I need to discover something more to gain the lvl 2 recipes?

  2. Yesterday my character died. When I returned to collect my stuff off the body I found the body right away but for some reason it would not open the corpse or allow me to llot it. I did get the message to press E to loot the body but it did not work.

Attempted several things such as moving some distance from the body then returning. Logging out and back into game. Nothing worked. I then logged out of the game for a few hours came back in my grave marker was still there but the body had dissapeared.

I am-most interested in the answer to #1.


You have to unlock each level of altar in your feats. Once you have enough zeal in the altar, you can upgrade them to level 3.

As for your body, its possible that if you can press E to loot it, but nothing happened, someone else looted it already.

1 Like

Thank you for the response. Much appreciated.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.