Altars disappearing when upgraded


#1

Whenever my friends or I upgrade Altars to Tier 3 for some reason it seems to be a 50/50 on whether or not the altar vanishes once upgraded. It has done this for both Set and Derketo altars, we have not tested it or experienced the issue with any other altars.

In order for us to reproduce the bug we
1.Place altar in what seems to be bugged location because if it doesn’t work there once it never will again
2. Upgrade the altar to tier 3
3.Watch altar vanish
I don’t know of a more detailed way to word this bug other than this, perhaps others could add their input please, i’m new here.


#2

I am not sure, but since they increase in size from t2 to t3, the geometry of the placing on the ground moves a tile forward. That may be what is happening?, to be sure make an extra foundations row on the front (not sure about the back) of the shrine and try again. T3 altars are known for suffering this issue since quite some time. I would try upgrading only when sure there are more foundations than needed just in case, extra foundations cost less than remaking a shrine and you can always take them down if not necessary.


#3

I have tried this, we placed all of our altars in the open after the first one disappeared, but it hasn’t helped. that was actually our first thought as to why it happened so we tried to fix it that exact way.


#4

They are bugged, it occurs to me that maybe it would be good to check before building the altar, that it can be placed not only in the spot you choose, but try moving the altar left right forward and backward on that same spot. I mean, maybe it is buildable at one spot, but a single meter away not, and that may be preventing the upgrade?. Sorry can’t help much. I know for sure the t3 upgrading has been problematic, but don’t discourage, it is possible to build them.


#5

i’ll try that but may take me an hour or so to upgrade to tier 3 again ;-;
I’ll edit if it works so others can try this.


#6

OK, so we tried this but it still just disappears and when i say disappears i don’t mean like it falls apart like it broke i mean it just poof, zips out of existence leaving a bag behind.


#7

Have the same Problem. Want to build it to T3 and than, it dissapears in front of me, all Items in it lost and all the Work for nothing.


#8

Some altars move when upgraded. Still.

Set altar going from t2 to t3 moves forward about 1 foundations distance.

If the new location won’t hold it, it goes poof, and laughs at your misery.


#9

Hey Chender, are you using any mods? Like LBPR or one of it’s varients for example? There is a bug that is somewhat similar (I’m the mod author). If a alter is picked up or moved (via a mod) after downloading LBPR, and moving it to an area that normally would restrict them from being built (like close to another alter), then the Altar will go poof. This is fixed by creating a bran new alter post-LBPR, and going from there.

Now I am unsure, as I never thought to test it, what would happen when one were to upgrade said new alter. I shall do so now though. Anyhoo, wasn’t sure if this was relevant or not to you, so thought I might chime in in case you are using LBPR, and in which case, if it’s a bug I can fix, for me to lock it down.

Edit: I tested it, upgrading works fine when using new altars and upgrading them in areas they shouldn’t be able to be built without the mod. So if you are using LBPR, make sure and use new alters post adding the mod, place them down, and upgrade and see how it goes.


#10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.