Alter of the Bat AND Alter of Chaosmouth missing/bugged on private dedicated server

Game mode: Online private
Type of issue: Bug
Server type: PvE
Region: EU-DE

On our private dedicated server hosted by Nitrado both the Alter of the Bat and the Alter of Chaosmouth are missing. Their textures are not rendered into the game and we cannot interact with them.

I tried all the tipps… relogging the player… restarting the server… validating client files… reinstalling the server… switching to testlive and back…

Only solution I found and didn’t try is the one I appended at the bottom of this post from Reddit user rex881122 (Topic ‘Private/Dedicated server missing server crafting stations (Forge of Ymir, Volcanic Forge) after using “servercleanup.bat”’ on the ConanExiles Reddit)
And that’s because it is beyond my expertise…

We had the same issue back in 2018 when we first played Conan Exiles but back then “only” the Alter of Chaosmouth was missing for us. I found plenty of post having this bug here on the forum but with a few exceptions nobody seems to get it working the easy way. :frowning:

Since Nitrado has their own routines to install/reinstall/wipe/reset their servers I have no influence that they don’t use the servercleanup.bat thus causing the problem. :frowning:

Should be simple for you guys to make a patch updating the game.db file like described on Reddit. Seems like the Alters are not the only bugged world forging stations… Please fix it. :slight_smile:

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. don’t know how to reproduce… just is the way it is on our server :frowning:


So I ended up finding a manual fix, the forges are stored in the actor_position table in the game.db, if you go into a singleplayer game, go to the forges so they get loaded into the game.db at least once, then you can copy the records from your singleplayer game.db into your server game.db you just have to set the id field to something unique in that actor_position table.

To find them, look for something in the class field for stuff like this:


If you read them it’s pretty self-explanatory which is which and if you used a clean singleplayer game, there aren’t many records to look through.

I was testing this with the Altar of Bats.

I have found no automated way to accomplish this so you’ll have to do it manually. I think they really need to fix their .bat file

If you use DB Browser for SQLite, you should be able to copy and paste the things below into a New Record in the actor_positions table. Just hit New Record, select the entire row by hitting the row number, Ctrl-V. You may get an error about unable to change rowid but that can be safely ignored.

Keep in mind to change the ID field to something unique. (the 25, 21, 19 in the three entries below)

And make sure the server is closed and you opened game.db after it was closed

Volcanic Forge

“36” “/Game/Systems/Building/Placeables/BP_PL_Volcanic_Forge.BP_PL_Volcanic_Forge_C” “ConanSandbox” “25” “346165.5” “-353598.90625” “-6467.171875” “1.0” “1.0” “1.0” “0.0” “0.0” “0.0” “1.0”

Forge of Ymir

“40” “/Game/Systems/Building/Placeables/BP_PL_Frost_Temple_Forge.BP_PL_Frost_Temple_Forge_C” “ConanSandbox” “21” “-128000.0” “-267584.0” “6735.84765625” “1.0” “1.0” “1.0” “0.0” “0.0” “-0.707106053829193” “0.707107543945313”

Altar of Bats

“13” “/Game/Systems/Storymission/BP_Storymission_BatTower.BP_Storymission_BatTower_C” “ConanSandbox” “19” “-62135.484375” “158682.59375” “-224.165512084961” “1.0” “1.0” “1.0” “0.0” “0.0” “0.161826223134995” “0.986819267272949”

Quick Upadte from my end:

Nitrado was so kind to implement the solution described in the Reddit-post for our Conan Exiles server hosted by them. ATM only for the Alter of the Bat but since we’re also missing the two mentioned forges and the Alter of Chaosmouth, hopefully those can be fixed the same way.

What that means:
Here’s the solution to that seemingly common bug on a silver platter for you, Funcom. Just implement a patch that checks the game.db for missing entries and re-enters them if necessary on every restart. That should be simple enough. :wink:

Here’s the missing information you need to repair the Altar of Chaosmouth. :slight_smile:

‘/Game/Systems/Storymission/BP_Storymission_ChaosmouthAltar.BP_Storymission_ChaosmouthAltar_C’, ‘ConanSandbox’, ‘15’, ‘-60599.8046875’, ‘30389.27734375’, ‘594.71630859375’, ‘1.0’, ‘1.0’, ‘1.0’, ‘0.0’, ‘0.0’, ‘-1.0’, ‘3.57627868652344e-07’

1 Like

That would be nice! They do have a server cleanup file now that doesn’t wipe the altars like before. I ran into your problem ages ago and it was a bit of work to restore, but at least it can be done now.

Since I’ve seen several people experience this issue (sometimes more than once), I spent a couple hours trying to make a mod for Conan Exiles that would scan for and replace missing altars and forges on server start.

It works, but unfortunately I can’t seem to find a way to make the replacements persist through sessions and get re-saved into the database, so such a mod would need to remain loaded until the database or underlying issue is patched, and any items left in the temporary replacement altars and forges would likely be lost forever when the session ends. Until I can figure out how to implement this better, or someone can point me in the right direction to get these actors to save to the database, I’m not sure it’s a good enough fix to bother publishing to the workshop.

Anyway, someone with better SQL scripting experience than I could probably write a better solution in the form of a script that checks the database for these entries and recreates them if they’re missing, until the issue gets patched.

Thanks so much for that Daedalon. :slight_smile:

We already have a few mods running so another one (especially if it repairs the game) would not hurt. :wink:

1 Like

Just to keep you updated:

Nitrado fixed the Forge of Ymir, the Volcanic Forge and (thanks to the data provided by Daedalon) the Alter of Chaosmouth for us as well.

So for now we’re good. But I think this bug is still something to solve for Funcom. Especially since it’s seemingly so common and so easily fixed with the information we have (the mentioned world crafting stations are just missing from the game.db file for some reason and have to be re-added).

Thanks for the help and feedback from you guys in this thread. :slight_smile:
Hopefully Funcom will squash this bug sometime now. :wink:

1 Like

Any feedback from Funcom on this?

Seems to me like a game breaking bug (unable to craft Black Ice stuff or Obsidian stuff without the forges, unable to finish the game without the Alters) that’s seemingly easy to fix for the devs. :frowning:

Not that I’ve seen reading around here.

I’m still investigating this issue further myself in the hopes of reporting enough detail that they can isolate the issue and fix it easier, but haven’t been able to reliably reproduce the disappearing altars and forges.

The only clue I’ve uncovered so far that might lead in the direction of the issue is that Altars and Forges, being containers that can hold items, are unique among the interactive objects pre-placed in the world. When a new game save is created, they seem to be moved to a list of persistent/saved objects that get captured in the game’s save database since they can hold items that players might understandably not want to lose whenever an SP session or MP server is restarted. This seems to be why nobody has ever complained about disappearing Obelisks, or the shelf in the Archivist’s room etc.; a fresh copy of these objects are loaded from the raw world data every session start. But these four are delegated to the save data and never loaded from the world again.

So the error must lie in the unique handling of these saved container objects, either preventing them from being loaded or saved. Maybe something during gameplay is resetting whatever flag marks them as a persistent object between sessions? The base object itself doesn’t seem to have any special properties that mark it as persistent, as I can add more of these to a test world and they don’t save between sessions.

I did manage to make the Altar of the Bat disappear once seemingly by teleporting directly into it and signing off. When I restarted the server it was gone and I was standing in an empty slot where the Altar should be, but several attempts to reproduce this with all four of these objects have failed. At first I suspected it might be an issue where the loaded objects can fail to place due to clipping/invalid location due to interference from another object, but unless it’s super particular about deciding when something is clipping into it or not, this doesn’t seem to the case.

Unfortunately that one time I managed to get one to vanish, I wasn’t able to determine if it had failed to save or failed to load, which could be an important distinction for the developers focusing their efforts.

I’ve exhausted ideas to use to attempt to reproduce and test this issue further for the time being. I’ll probably go pry details on other bugs from the game and come back to this one later.

1 Like

I admire your tenacity. :slight_smile:

rex881122 from the Reddit post seemed to believe that the problem was tied to the servercleanup.bat at least in a lot of cases. I do think that a lot of game hosters use that batch file to deploy new copies of Conan Exiles servers instead of really installing them. Thus causing the error for us for example.
There is a batch file to repair the game.db file in the same folder but all that does is check the database file for consistency.

But even without a reason for the disappearance of the forges/alters there’s obviously a simple solution to fix at least the symptom (just check game.db and add forges/alters if needed). Why does Funcom not just patch at least that?

They could even be so lazy to just add some lines to the before mentioned database checkup batch file for the alters/forges to make repairing easier for hosters. :wink:

Hey there,

We fixed this issue in June last year and it was tied to a faulty script (servercleanup.bat).
This issue reoccurring means that somehow the old script is still being used. We’d recommend using the new one or contacting the server host in case they’re still using the now 8-months-old version.


Hey, Ignasis.

Thx for the info. I’ll relay that to Nitrado. Hopefully that will eliminate this bug for future installations by them. :slight_smile:


You mentioning that batch file script accidentally deleting these back in the day made me realize what I had probably done to cause it to disappear from my own game during testing. I’ll file a separate bug report for that one. :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.