Missing Ice Forge, Obsidian Forge Chaos Altar, Bat altar

I run a dedicated server with mods, but also tested without any mods. My problem is I have no Chaos Altar, No Obsidian Forge in the volcano, No Ice Forge in the Giants cave and no Tower of Bats Altar.

At first, I thought this was some sort of level issue, so I just waited until I was up to 60 to retry. Nope. I have tried some suggestions from older threads about this, but nothing has worked.

Does anyone know what file has the information for those objects? I can do a completely new install, copy that file and paste it into my current game for a possible fix. If someone knows of a better option, I would love to hear it.

I know this is testlive and I should be fine with the game breaking, But I would love to solve the issue and have the answers for any future folks that get this on their dedicated servers.

The problem does not exist in my single player game.

Do you mean the structure is not there or that you can’t use it?
I had the same problem on my server, when I clicked on either of them nothing happen.
But I thought it was because of the Mods I use, but I need those mods so ….

the structures are not there. The Ice forge fires burn, with no forge to support them. Nothing to click on or open.

I know this what an issue some time ago in the live build for some people.
One trick was switching to testlive and back to fix it. But not sure what create this missing structures thing, not if it may still work now.
May be also server related if in your singleplayer you have them.

Maybe a new re-update to current patch ?

Still nothing on these. Anyone happen to know the file where these structures are stored and what lines of code need to be present for them to appear?

Bumping so this doesn’t get lost in time.

Any devs have any clue what is going on with this one? Some idea of how this can be fixed?

So this is it. I have a couple months on my server, with other users also invested in their bases. I ran the servercleanup.bat file when I restarted my server a couple months back and it seems this is the root of my problems. Does anyone know how to put those default server craft stations back in the game? Maybe a “FixTheServerAfterRunningServerCleanup.bat” file?

At the very least, even if I can’t be resolved, that file NEEDS to be removed from the dedicated server download, until it gets fixed properly.

@Ignasis You should tip off the team that this issue exists, if you have not done so already.

@anyoneElseListening Do you think it is possible to start a fresh server and somehow restore my most recent backup, yet still retain those craft stations and altars? Is it possible that the backups don’t actually record the built in server craft stations and altars?

Ok, I decided not to quit looking and found a post on Reddit: https://www.reddit.com/r/ConanExiles/comments/a8vvqh/privatededicated_server_missing_server_crafting/

I’m not a database guy, so was unsure how this would work, but it wasn’t too bad. Found everything as described and made the copy from a single play to my dedicated server and now all is happy in my conan world.
Imgur

I would still like to see the ServerCleanup.bat fixed, so this doesn’t happen to anyone else. Maybe edit it so it runs the cleanup, then replaces those lines back in the database? I bet it would not be difficult.

1 Like

Well I bookmarked that for future reference at the very least. Nice find.

1 Like

Hey @sirvink

Sorry for the late response! We sent this information to our team and they’ll look into it :slight_smile:

2 Likes

Ah perfect! Thanks again for your help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.