Anarchy Online Item Assistant Plus

Does anyone know a way to get in contact with Dream?
I tried per forum mail month ago but got no answer.

Try on Discord. It’s way more active then here. Discord link is in the AO launcher.

For some reason AOIA+ Looks at a wrong prefs folder for me. Anarchy Online does works for me with my prefs. Say my folder is 12345678(not real) and when i look in AOIA+ is see it looks in abcdefgh(also not real name). Both are in my: AppData\Local\Funcom\Anarchy Online. Where does AOIA+ get its setting from with the first install? Or is there a setting wrong in Anarchy Online. I tried to move/rename the wrong prefs folder and reinstall AOIA+. But is keeps going to the wrong prefs and crash. When both prefs folders are used AOIS+ cant see my backpacks but it sees my alts in the summary, but the inventory inventory cant be used.

@Dream Just bringing it to your attention that AOIA+ has been taken down from Sourceforge

Yes, I had noticed. But thanks for the heads up!

@ Spathilludic it calculates it from the AO install you pointed it to to use. You can also set up for it to use 2 installations; AO Classic and AO New Engine … those can be found in the menu options.

Temporary Home for AOIA+ 2019 (at least until I finish up some of the new updates on it)

Anarchy Online Item Assistant Plus 2019 v1.3.0.6


Thank you Dream for your tools. I tested it with new install of AO on another pc. There it works. The install ao i use on my is just an old copy over from my previous game pc. I will try it with a fresh install.

I just reinstalled ao and the new client and everything is working now. Thanks for the support Dream.

Thanks a lot Dream! :slight_smile:

Aha, I am glad you were aware your 2019 edition was gone from Sourceforge. I had to re-install AO today on one of our 2 pc’s and then couldn’t find AOIA+ 2019 online. Thankfully the other pc still had the download install file from Dec 2019.

Will the new version be on Sourceforge when it is ready?



1 Like

I’m looking into it having it’s own website. There is also a new version in the wings, with the ability to create sets of items that you can name for easier browsing (ie buff gear etc). It also will have a UI template system, allowing you to save all key UI positions from a toons set up and then transpose them to other toons; this is handy if you have different sized monitors on different machines but want to share your prefs still, it’ll be a one click update UI for all toons.

Anyway, watch this space for more info…


UI transfere between characters will be amazing thank you sir !

Is there some kind of documentation for AO Item Assistant? I’d like to reset my database to remove characters that don’t exist any longer.

edit: nevermind figured it out

Is there any folder structure that needs to be followed (Win10) ?
I can’t seem to get the program to launch (installs ok), it goes as far as asking for admin permission (UAC, I click yes) but then nothing happens.
I’m abit lost as there is no error message, nothing.
Anyone else ran into similar issues ?

Sounds ok, just check if the AOIA Icon is at the right side of your taskbar. Maybe you have to press the ^ Button to see it.

I just noticed that the summary screen isn’t updating my characters’ org memberships. For example it’s still showing my fixer in his previous org-- which died in the before times (pre-COVID) & he’s been prez of a different one for over a year. It’s a minor thing but would’ve saved me a few relogs today.

Can’t wait to see the next version!

1 Like

Nope, it refuses to launch anything, nothing on the taskbar either.

Fresh install, loads the nanos and everything but then exits saying it needs a valid DB.
Logs say:
Db::Exec: Failed to execute query [INSERT INTO [tblAONanoCrystals] ([crystal_id], [crystal_name], [crystal_icon], [nano_id], [nano_name], [nano_icon], [disc_id], [compiled_id], [program_id], [ql], [type], [school], [strain], [strain_id], [substrain], [substrain_id], [fp], [sl], [sl_spec], [nanodeck], [profession], [location]) VALUES (301144, ‘Nano Crystal (Release Me Now!)’, 301143, 281239, ‘’, , NULL, NULL, NULL, 25, ‘Crystal’, ‘PvP’, ‘Self_Root/Snare_Resist_Buff’, 283, ‘Lost_Eden’, 0, 1, 0, 0, 0, ‘Keeper’, ‘OFAB Store’)]. Error: 1, near “,”: syntax error
Failed to initialize DB Manager. Aborting!

help pls!

My issue was due to my windows username that contains a special character “ó” and he uses that name to create the folder in users\USERNAME\appData… and AOIA couldn’t handle that path name and crashed. I created a new win user and it worked, maybe something you can check out.

So my AOIA+ is no longer showing when Nano Programs are ‘Uploaded’ on characters, in the Nano Programs tab. Anything I can do to fix this? I tried restarting, zoning, re-configuring the AO folder. So far nothing has worked. It shows all the QL 1 nanos as uploaded, but nothing else.

Windows 10 updated this week and broke both AOIA and AO client for me. AO launcher ran normally, but the client just immediately closed with no hint about why. AOIA ran… forever… without doing anything. [edit]Okay, clearly not “forever”, but at least for hours that seemed like forever.[/edit] Task Manager says it’s fully utilizing one processor 100% of the time, but no window comes up, no notification bar icon, nothing. And clicking the shortcut again doesn’t un-minimize it, because there’s no window to un-minimize. It just starts another copy doing the same thing.

I tried to uninstall the two Windows Updates and I think one of them worked and the other may not have. It still lists the option to uninstall it, but fails to do so. So one might still be partially installed. [edit]It’s KB5007186 in case anyone else is having a problem with it. And the one that did uninstall was KB4601554.[/edit]

After uninstalling, nothing changed, but all my other AO installs worked for beta and test. I had to reinstall AO classic and rejigger all my maps and helpfiles and configuration and gui defaults and whatnot, but I got AO working again. AOIA still doesn’t work. I reinstalled, uninstalled, redownloaded, reinstalled again, tried some compatibility options. It still just starts running enough to keep one core 100% busy, but even after leaving it over night, there’s no window opened or minimized.

Any ideas what I could check next?