Anarchy Online Item Assistant Plus

My issue was due to my windows username that contains a special character “ó” and he uses that name to create the folder in users\USERNAME\appData… and AOIA couldn’t handle that path name and crashed. I created a new win user and it worked, maybe something you can check out.

So my AOIA+ is no longer showing when Nano Programs are ‘Uploaded’ on characters, in the Nano Programs tab. Anything I can do to fix this? I tried restarting, zoning, re-configuring the AO folder. So far nothing has worked. It shows all the QL 1 nanos as uploaded, but nothing else.

Windows 10 updated this week and broke both AOIA and AO client for me. AO launcher ran normally, but the client just immediately closed with no hint about why. AOIA ran… forever… without doing anything. [edit]Okay, clearly not “forever”, but at least for hours that seemed like forever.[/edit] Task Manager says it’s fully utilizing one processor 100% of the time, but no window comes up, no notification bar icon, nothing. And clicking the shortcut again doesn’t un-minimize it, because there’s no window to un-minimize. It just starts another copy doing the same thing.

I tried to uninstall the two Windows Updates and I think one of them worked and the other may not have. It still lists the option to uninstall it, but fails to do so. So one might still be partially installed. [edit]It’s KB5007186 in case anyone else is having a problem with it. And the one that did uninstall was KB4601554.[/edit]

After uninstalling, nothing changed, but all my other AO installs worked for beta and test. I had to reinstall AO classic and rejigger all my maps and helpfiles and configuration and gui defaults and whatnot, but I got AO working again. AOIA still doesn’t work. I reinstalled, uninstalled, redownloaded, reinstalled again, tried some compatibility options. It still just starts running enough to keep one core 100% busy, but even after leaving it over night, there’s no window opened or minimized.

Any ideas what I could check next?


We haven’t heard from you in a while. Hope all is well with you!

You were RK19’s savior with this version. We have a lot of people asking if there is a website to d/l it and, as AOU staff, I’d be honored to add it back on the Anarchy Online Universe site to help them out.

I know you have a temp d/l page out there, but you’d mentioned moving it to another website if IIRC? Any chance that it’s out there somewhere and we just are not seeing it?

I’ll shoot you an email but I was hoping you might see this, first!

1 Like

I love this tool. Its only way to keep track all my toons inventory

I just had crashes in aoia and uninstall and reinstall isn’t helping. I was deleting some char prefs folders and making a new char and think that f it up as it wasnt running and tracked changes. I am not sure. Anyways I didnt touch anything in aoia it just crashed outta the blue and I deleted pref char folders before so. Weird…

Hey All,
I have deleted old toons etc with no backup recorded and still got ghosting i have deleted every trace of AOia and still when i install every char is still there, its driving me nuts…can someone with a clue please help me out…

Nothing short of awesome this program is by the way :slight_smile:

If you want a clean install and start again %localappdata%\Hallucina Software\AOIAPlus
delete this file.

In case anyone else runs into the same problem I had, with AOIA locking up before fully starting or opening any windows, I have a guess why it’s happening and a fix for it. I can’t prevent it from happening, since it seems to occur when AOIA is running and my failing video card causes a kernel panic that reboots the machine. I now keep a backup copy of “%localappdata%\Hallucina Software\AOIAPlus\ItemAssistant.config”. Just a Ctrl-C Ctrl-V simple copy in the same folder, since nothing else there seems affected. I use Resource Monitor to Stop Process on ItemAssistant.exe first, so there’s no open file handle in the way, then delete the config, restore from the backup copy, and restart AOIA. Works every time so far.

1 Like

Is the source for the latest version (AOIA+) available today?

After doing some testing, I’ve observed that the GMI column in the Summary holds a maximum value of 4,294,967,295 and not an integer value more (the max. value of Int32). After this, the software will omit the entire line from being rendered due to an underlying exception, while continuing to render the remaining toon records from the database.

Clearly, this should have never been an issue because GMI doesn’t support more than 3.999b. However, these days with the messed up economy and everything being up in the multiple billions, it is possible for players to have in excess of 100b in their GMI balance. So, during what should be a normal update of this column in AOIA+ with GMI opened, this field is simply not getting updated because the field is too small (of type Int32). In order to restore functionality in this post-inflated economy, this GMI int field would need to be refactored as long (Int64).

The other column types are adequate as-is because the game would not support values exceeding their type size. But the GMI balance in-game, as many of us have seen, is capable of sizes far greater than Int32 today.

1 Like

Another way of doing it without changing type is to round in like M or B
Up to the AOIA dev to decide :wink:

Taking occasion here to remind that AOIA /loot autoscripts sometimes misses 1 or more items from bosses that have huge list as Beast or 12m Xan, for examples.

you know what would be a cool feature?

when searching for items, what if we could check a box to show the toons that dont have that item? would come in handy a lot. (unless theres already a way to do that and im dumb)