Attribute Points Issues

PS4
Official Sever

I am playing Isle of Siptah and I reached lvl 60 and only have 378 attribute points to spend instead of 390.

I tried drinking the potions to see if it would fix it and just goes to 378 every time, I really do not want to recreate my character.

1 Like

390 is standard. Sounds like a bug. Try using a potion to reset your attributes, it may fix the issue.

1 Like

Alrdy tried several times, I really don’t want to recreate my character lol

1 Like

Sadly, only thing I can say, is bug report the issue in platform you play in.

This has happened before. Can not remember witch console or how it was fixed but I am fairly certain it was @Community

2 Likes

Greetings @WickedWayz,

Thank you for reaching out to our community and welcome to our forum. We’ll send a direct message to you so we can gather further information regarding your account.

Please make sure to check your forum notifications. :slight_smile:

4 Likes

Thanks for the quick reply.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.