BattlEye - Cannot launch the game


I just purchased all the Conan Exile games — think It looks fun and want to play. When I launch the game it crashes and gives me this error.

Failed to initialize BattlEye Service: Driver Load Error (1275).

I have researched the issue and found there to be an incompatibility between Microsoft Windows 11 security enhancements and the BattlEye service you use. Microsoft and many other forums do not recommend disabling the service in Windows which will allow me to play your game. I tend to agree and do not wish to make my PC vulnerable because you all are using an old and outdated anti cheat service.

Bungie and Destiny had this issue and they fixed it. Fortnite also had this issue and fixed it. And they fixed it without having to ask their players to do something that could harm their PCs. Where are you Funcom? Should I ask for a refund or do you plan to fix this?

Appreciate your response.

1 Like

can I please get a response?

I’m on Linux. The game played fine just two weeks ago, and this update completely bricked the game for Linux users.

If you look at my post history, I also complained about this in February. They’ve broken the game several times in one year now - all they have to do is just leave it alone and focus on their next game. This isn’t a beta project. It’s a mature game that people expect to work a certain way.

If Funcom’s developers want to try something new with the combat system, then they should do so in their next game.

Yet another reason not to update to W11.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.