Black screen after loading character

I was in transylvania just about to enter inside the dragon’s tomb, the loading screen to dragons tomb was stuck (happens a lot whenever I try to enter another area inside a map) so I forcequit the game. When I tried to log back its just a black screen after the loading screen, can someone help me? My character its pretty much stuck and unplayable D:

Can you specify which loading screen? The more details the better

Do you see the UI or nothing at all?
I don’t know if it’s your only character, but if you have an alt, are you able to log in as normal on another character?

The screen right after you select your character and click to play with it

I tried another account (made one just for that) and it worked fine in the tutorial zone, this problem seems to be related to my specific character.

I see nothing at all, just black, yestardey a saw a quick view of the normal screen with daily login rewards window and all, but it was just 1 second then everything turned black again :confused:

Eeep! So nothing interface-wise? I was going to suggest typing /petition in chat if you hadn’t already, but that is sounding very borked indeed!

Shot in the dark, but maybe attempt to type /reloadui in chat. It might type even if you can’t see it.

I assume you did a restart of the computer?

Oooh or hold ctrl, shift & F1 maybe?

Sometimes one works, sometimes the other. Cant hurt to try at least!

1 Like

Apparently the issue was related to my computer + the character being loaded inside the tomb and not outside in the open map, so I asked a friend to login my account and take my character out of there for me and it worked


Glad to hear it got fixed =)