Bower of Jhebbal Sag Not Placeable

Game mode: [Online]
Problem: [Bug | Misc]
Region: [US]

I have a platform of 5x5 foundations, I am planning on centering the Bower on the platform.

The placement is not possible for some reason. How big should the placement be, all other alters can be placed on this sized foundation platform.

Steps on how to reproduce issue:

  1. Have Bower of Jhebbal Sag feat
  2. Make 5x5 foundation platform
  3. Try to place Bower
  4. Fail to place Bower

It could because you already have walls built around the space. It looks like some may technically be on the tiles you’re trying to use, and therefore interfering. Basically the altar thinks there’s only 3 tiles wide of available space.

You might be able to get it placed if you take down all the walls surrounding the space, and move that thrall temporarily. You can then put it all back after you place it.

That’s one of the altars that are kinda picky. I had a similar problem with the Derketo altar recently, and did some testing with all the different base altars. I needed a 5x5 space that was completely unobstructed to place it, then i was able to destroy the 5th row of foundations and build the wall behind afterwards.

I tried to minimize the surrounding objects, still not possible to place.

I label this as a bug because all other alters are possible to place in this type of situation without removing all surrounding objects. However, the alters do have placement issues, I believe this main issue is more interesting to cover since this prevents the alter from being placed.

Often with large objects they do not register as being in contact with the ground when aligned with foundation edges or evenly spaced on foundations. Have you tried moving the alter around in the platform to see if the message disappears … it might place if mis-aligned / off centre just a little …

this is one of the most frustrating aspects of placing objects for me … that to place them I have to end up with them crooked in relation to the foundation base they are on … why oh why couldn’t they have coded a toggle on/off “ snap to grid” function :unamused:

I have tried all possible placement on the platform. It is placeable in the middle of a flat part of the desert near my base, but it is not needed there.

This should be a bug since, as I above stated, all other alters are placeable in this type of building, in various stages of build. Why is the Bower not cooperating. The next biggest alter is Set for area and Ymir for the level 3 design. Both was placed in partial built structures since I had to rebuild to correct for “level 3 jump” bug.

I was having this problem myself earlier this evening. Had to have the foundation/platform quite a bit larger than the alter. Think mine was either 6 or 7 by… and then got trimmed from there.

I find it interesting that the error message you’re getting has changed. Leads me to think we solved part of the problem, but there are multiple issues here.

It’s hard to see the whole platform from the 2 pics you’ve provided so far.

Since it looks like you’re building on very uneven sand dunes, do ALL the foundations go down to the ground, or do you have a little overhang around some of the edges? If you have any of them that are getting their stability off of another connecting foundation, and not from the ground, that could cause the contact problem in the last pic. Make sure every foundation piece has full stability down to the ground.

You could also try checking the stability of all the foundations with a building hammer to try to see if that’s the issue.

The platforms are 5x5 with foundations all the way down to the sand. It is all built on the same snap grid as the pyramid.

I was going to make a room in each platform, but the slight difference in the surfaces of foundations and ceiling pieces put me off of that.

The only other thing I can do is build the platforms bigger, but that will prove expensive since I will be demo-ing a lot of pieces and rebuilding it after placement just because the alter has a larger area check zone for placement.

I’m not sure why you’re having trouble. I was able to place one in singleplayer on a 5x5 platform when I was testing.

If building it bigger will work, then you can build the pieces you know will be demolished out of sandstone and save yourself the extra materials at least.

The other thing I am thinking that is preventing this from being placed is the ceiling pieces to the front and back of the platform. Since the slight difference in the height of the pieces.

Finding a workaround for this issue is frustrating. I might try something out when I have a chance.

Meanwhile, this issue should be looked into on FunCom side. The latest patch on PC states that placement check box has been updated to better aid in placeable. Not sure if they touched the alters to though.

I have taken down the wedge piece as well as the floor and steps up to the platform. Same not enough contact with ground prompt when attempting to place alter.


I’m at a loss. Sorry.
The only thing I can think of at this point is to try @Rennia’s suggestion and build it out to 6x6 or even 7x7 to place it, then shrink it back after you get it placed. You should be able to use sandstone for that at least.

I would also try going into singleplayer and testing before spending more time and materials troubleshooting online. That way you can admin in everything you need, and figure out how to make it work first.

Before you do that tho, try removing the 2 ramps on either side. If the ceilings were causing a problem, they could be as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.