Broken fish trap

Game mode: [Online
Problem: [Crash | Bug
Region: [Here]

After many attempts at different locations I have had 0 success placing a fish trap anywhere. All it ever says is invalid placement and must be in water

Steps on how to reproduce issue: fish trap
2.try to place fish trap


Try to build a base in the water and then place the fish trap on there, It works for me, hope this will help you

Worked for shellfish trap but not regular trap

I placed 6 fish traps and 6 shellfish traps just this morning with no problems . The improved versions if that makes a difference. Working fine in the big pond outside asgarth on official.

I haven’t tried improved traps. Could some check on the tail of sperm river with normal fish traps. I have gone up and down that tail with 0 luck. And for those who ask “where is sperm river?” You really can’t miss it on your map it’s literally the only body of water shaped like a sperm cell

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.