Broken quests and nonsense

I stayed away from this new version of the game for years. But, I miss the secret world and you have removed all the argatha teleport conduits in the actual real game. So, I decided to give this trash a try. The quests are broke or so damn vague that I have to be a moron to understand it. This is due to you removing the quick bar inventory widget, in leiu of the temporary quick bar function, which is broken. First I tried to complete to sir with love, dumped the blood, but there was no mirror to place on the ground because my temp quick bar was full of blood. Then I tried to do the black house and couldn’t dump the ashes because it blood was in my quick bar though I paused that mission. It didn’t overwrite the quick bar, and there is no interaction widget. Then I removed the blood only to realize I could not abandon the quest and start over again, so I don’t have the tools to do the quest because I destroyed them to make room for a new quest that was suppose to be less frustrating because I have done it about 4 times in the past in the original game with no issues. NO WONDER THIS GAME IS DEAD.
I have a suggestion, why not reopen the old game as we can log into it anyway.

Your post is such a mess. I get barely 1/3 of what you write. Did you just delete mission items? Even though you have mission bag i inventory where all mission items stored allowing them to take no additional room in inventory? So it’s you actual problem? Or… you don’t know about separate bag for mission items? Which most likely had items from paused missions. Though game usually overwrites it when you unpause missions and tier says you to take something. You can use them from inventory too, not necessary from quick bar.
Try to take a deep breath and explain again, using paragraphs and some proofreading, what happened.

This quest works exactly like it did in TSW. The only difference is that the game puts some of the items into your shortcuts bar, but only if there’s room. If not, put them there yourself.

1 Like

Not seeing what your problem is tbh :v:

You know that there’s a bag for Mission Items, right?

The quick access slots aren’t the only way you can use them, you can also open your inventory and click on them (like we did in TSW). You can drag items on and off the quick access bar and they’ll still be in your inventory, but simply picking up a new quest item won’t overwrite what’s in your quick access slots. Only completing the mission and removing the item from your inventory will automatically remove them (or if it’s a single use item). It’s unlikely that you actually destroyed anything, most mission items can’t be destroyed now, and they don’t count towards your inventory limit, so there’s no problem with keeping loads of them (which is why there are still items for summoning Hel in my bag for example).