Broken The Dregs

Basic Info:

Platform: PlayStation 5 (Digital Edition)
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvP
Map: Exiled Lands
Server Name: 3605

Bug Description:

The Dregs Dungeon is not giving me The stuff for reading the book

Bug Reproduction:


I have been through the Dungeon 2 times doing the same thing and never once got the stuff I was supposed to get This has been an issue since the release of the Sorcerer’s Update that released and still has yet to be fixed.

I do have video proof on my youtube that I should have gotten The Dregs

Hey @InevitableNegan ,
welcome to the Forums.

From your bug report I think what you are referring to is the Book that you can click on to learn the Abysmal Recipes, the armor and weapons is often invisible when you defeat the Abysmal Remnant. The solution for this unfortunate state of affairs currently is to click at the base of the stairs like a mad person after the Abysmal Remnant has been defeated and the acid temporarily drains from its hot-tub-of-ickiness.

Your follower may or may not inhibit you while trying to randomly click on an invisible book, so you may want to consider temporarily getting your follower to stop following until you click and get the new recipes alert. Before exiting the dungeon don’t forget to get your follower to resume following.

Hope this helps. All the best.
(If you need to know the exact location of the book, to know where to click-spam, watch any of the older walkthrough videos on youtube, the location hasn’t changed, the book just doesn’t always render now.)

as stated I have a video that shows me that I should have it I clicked on it but it’s still not on me is what I am saying I don’t have the knowledge I should have.

Gotcha bro, sorry.
Didn’t see the video you mentioned, maybe include a link or some such, might help speed up suggestions by folks.

Good Luck.

it won’t let me post links I tried to at the start but it refuses to let me post links [Preformatted text]( a link to my youtube video of what happened when I beat the Dreg.

Hey bud, okay I was able to see your video,
I don’t have access to my game right now, but I see that you got the book okay.
Then as you are were checking for your Knowledge, one of the items learned is Herpetology, when you were checking your Knowledge I did not see you check your armor recipes. Seeing Reptilian Armor Recipes would indicate that the recipes were learned.

It looks to me after reviewing your video you were looking for the glowing goop torch recipe. the glowing goop /dredger recipes those are learned at the tablet immediately at the entrance to the Dreggs, just trying to be complete here, because I am not sure exactly what recipe is missing for you. Hope that is the missing piece for you.

Someone else may see something I am missing. If what I threw up here helps great, if not sorry bud, I really only replied initially because I thought you were a new player with a simple misunderstanding. The video shows you hit the book I’m not sure which recipes your knowledge tabs are not showing. Best of luck man, sorry if I am still misunderstanding your Bug.
Screen Shot 2023-01-11 at 1.42.26 PM

OMG, now I feel like an idiot are you telling me that the glowing goop and stuff like that are at the start?

1 Like

Dude, awesome, yeah its easy to misunderstand other people’s questions.
Right on, I had to watch your video a couple times before I saw you hovering over the torches. Glad I was able to help.

(Don’t feel bad, we’ve all done it. )

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.