BUG: All 80 of clan's thralls wiped upon login

Basic Info:

Platform: Steam
Issue Type: Gameplay
Game Mode: Online Official
Server Type: PvE
Map: Exiled Lands
Server Name: 1730
Mods: None

Bug Description:

Logged in after restart, noticed that none of my thralls were showing. Relogged. Still none of them showing. Checked the event log and noticed that ALL of the thralls from our Clan are GONE.

80 thralls, most lvl 20, fully equipped with end game gear.

This just happened.




Proof that Ive been on recently, since I gave my neighbor a recipe.

Thank you for the update @CodeMage. I also lost thralls on several servers. I am hoping some action is taken quickly to rectify the thrall decay. I recall back when sorcery first came out there were issues and Funcom rolled back the servers 24-48 hours. I lost everything I did during that 24-48 hours. I fear if swift action is not taken to roll-back 24-48 hours sooner than later you are going to have even more upset players because they will have lost twice. I was hoping when the restarts were going on today that the server was actually being rolled back, but it didn’t. Please roll back tonight, so we can play Conan this long weekend and not fear losing even more. Thanks

Just to set the record straight, I can’t roll back anything, because I don’t work for or with Funcom. I’m just another player. I didn’t write the post I linked to above. I merely posted the link so that OP would know what happened.

Im so mad I shouldt type right now, but I feel ur pain.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.