BUG: Building stability on restart

Game mode: Single-player
Type of issue: Bug
Server type: Any
Region: N/A


When starting the game, stability of existing buildings isn’t propagated or calculated correctly for certain cases. I have found one consistent repro, which I will describe here, and I will add more information as I experiment further.

I haven’t tried reproducing this online yet.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Place a pillar.
  2. Place a ceiling on top of the pillar.
  3. Attach a wedge to the side of the ceiling.
  4. Attach another wedge to the side of the previous wedge.
  5. Attach a ceiling to the side of that last wedge.
  6. Observe that the stability of that last ceiling is 40, which should be enough to keep it stable.
  7. Restart the game/server.
  8. Observe that the ceiling is missing.

Here are the pictures showing the repro.

Steps 1-5:

Step 6:

Steps 7-8:

Note that I have tested this with both T1 and a variety of T3 materials, with or without foundations. The T1 material I’ve used is sandstone. The T3 materials I used is Arena for the foundation, Stormglass for the pillar, and Black Ice for the ceilings and wedges.

I have also observed the same behavior for other combinations of T3 materials.

I will keep experimenting with different combination of building pieces – more or fewer ceilings and wedges, in different layouts – and add information if I find anything new.

8 Likes

Wedges can make great building, and bring variation, but i avoid them often for that reason.
Stability on wedges has still been an issue, also i mostly avoid put my chests with precious stuff on them. Barely had chest vanishing on normal foundation or square ceilings, but wedges yes. Stairs and ladders on them are also tricky.

1 Like

kudos in providing easy reproduction of the issue.

2 Likes

Yay reproduction steps! Based on the steps provided, I was able to reproduce the issue.

2 Likes

I’ve been experimenting more, and I have more to report. Fair warning, this post will have a lot of images and some mind-numbingly boring information :wink:

This bug only manifests itself under very specific circumstances. It has to involve a stability graph with a ceiling attached to two side-by-side wedges, attached to another ceiling, like this:

or like this:

As per the images above, it doesn’t matter if the wedges are arranged clockwise or counter-clockwise, but they do have to go in the same direction. For example, the following combination is not affected by this bug:


Another thing I discovered, which should help speed up testing, is that you don’t need to restart the server. You just need to change the stability of the wedge that isn’t directly attached to the last ceiling:

In the example above, if you place a pillar bellow the wedge indicated by the red arrow, and then destroy that pillar, the black-ice ceiling will lose stability. If you place a pillar below the other wedge and destroy that pillar, the black-ice ceiling will be fine.


Here are some more test cases where the bug does manifest:

image

In all of the images above, the black-ice ceiling will lose stability.


Here are several test cases where the bug does not manifest:

In the images above, the black-ice ceiling will not lose stability.


I apologize if this went a bit overboard. I realize that this bug only manifests in certain very specific cases that won’t affect the majority of the players and that it’s easy to work around it by adding redundant stability. However, I’m hoping that by finding the root cause of this bug, you guys might be able to discover the root causes for other stability-related bugs.

11 Likes

Great job, CodeMage. You may have solved the mystery!

3 Likes

Absolutely greatly documented, tks lot ! :+1:

That’s crazy, i knew it was the wedges, or linked to, but these different configurations are just stuning.
Sure, some ceilings it may be easier to manage, but this explain also why some did experiment this bug while others not at all.

2 Likes

Hey @CodeMage

Thank you for the detailed report. This is actually an issue we were trying to reproduce on our end again for a likely fix in the near future, so thanks a lot again and for the well-timed report.
We’ve sent it to our colleagues who are trying to squash this nasty.

3 Likes

Hello hello,

Quick update:
The day has cometh! We have an internal fix for this issue undergoing QA tests. Thanks again!

6 Likes

kAtQIv11

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.