Incorrect stability when building results in missing pieces

Game mode: [Enter game mode here: Online official
Type of issue: [Enter one of the following: Bug
Server type: [Enter one of the following: PvE-Conflict
Region: [Please enter your server region] EU


Incorrect Stability on building pieces causing them to lose stability and disappear, eg attach a ceiling tile to a wall (with 100 stability) ; ceiling tile has random stability between zero and 60. If zero, it has disappeared by next log in.

***





Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. place a foundation or wall with 100 stability
  2. Attach ceiling tile to this and its stability is anywhere between 0 and 60
  3. if stability of zero, it has disappeared by next log in and event log says in red it has lost stability
    4.replace ceiling tile…stability still shows as zero!
1 Like

I can’t believe no-one else has encountered this. Just me then, I guess.

Do not give up it takes time for anyone on the forums to get back to you when you report a bug.

Hey there,

Thanks for your feedback, we’ve relayed it to our team so they can look into it.

2 Likes

Hi there I have the same issue as you have, unlogical stability calculation. I hope it is a bug and I hope it is fixed soon. My issue showed up for the first time on a +/- 15 stories high tower while trying to finish the roof so no fun task to close the gap after a possible fix.
Below is the outline of the roof;


The 6 center tiles are supported with beams from the ground floot all the way to the top floor. So these all have 100 stability.
Below is a picture of the tile that has the normal stability of 40;

And below is the picture of the tile in the same round that only has 20 stability, I can’t finish up the roof on it’s edge like that :frowning:

I don’t think it only happened to us but I neither think it is a bug that happens often …
Hope the dev’s notices this because if a computer program can even no longer calculate stability than it has a serious issue. :stuck_out_tongue:

2 Likes

Based on the little information you have provided, there isn’t a bug here. Sounds to me that you didn’t set up the pillars correctly. Pillars must connect to each other from a foundation source, or the ground. If they don’t, you get what you are seeing. That’s a game mechanic, not a bug.

The issue that the OP is posting is completely different from this.

Multigun; my pillars are 6 pillars starting from the bottom floor all the way to the end (middle 6 wedges all have pillars beneath them) and this for 15+ floors high. no issues anywhere.
In the end I solved my stability issue due to the roofs coming over it.
If you look at the given set up you see 6 wedge foundations all with pillars beneath (=100 stability) than you have the frontier ceilings attached (=80) stability
The wedges between those ceilings have 60 stability which means that the frontier foundations attached to those wedges should have 40.
All except one has the logical 40 stability. So yes this is not normal
You can do the math yourself if you like :wink:

Below is the picture of how it currently look from the ground; it is the right tower that has this issue. I solved it due to the stability from the next layer in the roof.
As you can see; stability wasn’t an issue otherwise I wouldn’t been able to finish it all the way up :sweat_smile: :wink:

I would try to explain how the socket system works and why you see 20 instead of 40, but that will continue to derail this thread in it’s intended purpose.

It is still a completely different “issue” then the actual bug reported on this thread.

1 Like

can you send to me your explanation by mail, cause no matter from what perspective I look at it; it isn’t explaining the issue I encountered at all :slight_smile:

Hey, @Delorre, have you verified that the 6 innermost stormglass wedges actually have 100 stability? If they do, then you’re right and there’s a stability propagation bug at work.

From what you’re saying, the innermost wedges should be at 100, the wedges in the middle “circle” should be at 60 and the frontier ceilings connected to them should be at 40, not 20, but that’s only if all the innermost wedges are at 100.

1 Like

So, quick update. I logged in today and checked event log to find more tiles, and even the underlying pillars had lost stability and disappeared:



So I built up a foundation all the way to the current level and pillars adjacent:

And put two ceiling tiles on top of the pillars…

So, I’ll see what happens tomorrow.

1 Like

did it work out after update?