Bug in "Flame Away" quest

Hello, I have a problem with this quest, I’m in phase 3 where I have to use the flamethrower on an enemy, but instead I used it at the Skatepark and it exploded, now the quest is bugged. Even if i go see Edgar in the scrapyard or try to refuel it, nothing happen. Even if i go back in skatepark and try to pick up the “unfinished flamethrower”, i only get the quest details. I can’t pause the quest it doesn’t reset. What should I do? Thanks.

If it helps, i’m playing on Steam.

After the Flamethrower explodes, the mission objective should change to
image
Did it not advance for you? I just tried it at the skatepark and it advanced just fine, there was no need to attack any enemy with it, I was just able to run to Edgar and the mission completed.

1 Like

No, after the flamethrower exploded, the next objective doesn’t change, i’m at “try the flamethrower” again. Nothing happen when i go see Edgar.

Hmm, have you tried picking up 3 alternative side missions? I know you said pausing it didn’t help, but that might force it to reset. Otherwise about the only option is to submit a /petition in game, and the GMs should be able to reset the mission for you :frowning_face:

1 Like

Yes, i have pick 3 side missions, but the quest doesn’t reset.
I have made a petition in game, wednesday, post a message in “The Secret World” page on Facebook, post a message on Steam (in french and english) and on this forum, i’m loosing hope.
I hope someone can “repair” my quest, it’s the only quest left, to have the achievement.

The customer service response times have been really slow lately, so your only real option is to just wait. It sucks, but hopefully they’ll get to you soon!

3 Likes

3 days after the last message and still no news, I have been patient for almost 2 weeks. I know it’s long before i get an answer, but did the GM forget me?

Don’t forget to check your ticket. You don’t get a message telling it’s been updated.

1 Like

I check my ticket each day and look at my petition too, no one has answered me, and my quest is bug and i can’t finish it.

My petitions throughout the 3+ years SWL has been around, have usually taken two weeks to get a response. Hopefully you’ll get one soon.

1 Like