Bug to join a server after the patch 23/03/21

Online Private
PVE Rôleplay

The game had a patch this afternoon and since this one, I can’t lauch a server by not using the modlist.
For exemple, I’m playing on GeForce Now and it’s impossible to play on a server because the game has to download the mod from the steam workshop directly in the game.

1 Like

I have the same issue. When I join the server, the download of the mods is queued up but never starts. I have tried unsub and resub all the mods in the workshop, doesn’t help. I have restarted the game several times and doesn’t help either.

Exactly… Thank you for the explanations and the screen.

No problem. I hope it gets fixed fast.
This only started happening since the patch today. I connected this morning 3 times to the server and it downloaded ALL the mods each time with no issues.

I have tried everything… Nothing works. Mods don’t start downloading, they stay in “queued” status on the modmismatch window.

Has the server side performed the Steam Update to get to latest version? If not then that may be the real issue.

It has. And this is not specific to one server, happens with all servers with mods. The issue is client side.

Have you tried setting up a matching local modlist.txt in mods?

It is not possible in this case. The author of the post and me both play on Geforce NOW, having no access to the file system.

Besides, editing that file is not the standard way of doing it offered by the game. The way we are reporting here that does not work is the way offered by the client to download mods. Modifications of the files directly are just alternatives (I would even dare to call them workarounds).

Anyway, it’s not possible in this case to touch anything in the filesystem of the machine. It should work anyway - it has always worked for me and I have been using this way of downloading mods (again, which is the standard way of doing it) for over a year with no issues, until yesterday’s patch.

I asked another user as well but is it not possible to load mods in single-player via GeForce Now? I am not familiar how it works.

On another note, the mod loader seems to be working properly for me. It shows me the mod mismatch, it loads the mods, restarts my client and connects to the server. It is not an universal issue but rather something specific to those using GeForce Now.

Some additional info by Testerle:

It’s not special because it’s Geforce NOW, it’s just that we do not have access to the filesystem. So any touch in files (deleting them, creating them, modifying them, is not possible). We are limited to starting the game with no mods downloaded/installed in the machine. So when we join the server mod mismatch comes up, the mods gets queued up but nothing happens. Yesterday I tried having that window opened for over 30 min, and nothing. I can try again, if others are experiencing it being slow to start. I can have it longer opened.

…which makes it special. worst case all the mod downloads for all games with workshop content comes from the same ip range and is limited by steam because of this. maybe open a ticket at gforce now and ask?

True. I was not aware of throttling from Steam per IP since I’m not sure which issue it would actually solve for them, but that doesn’t mean someone didn’t implement that.

Thanks for the tip. Will check with them.

massive calls from a limited number if ip adresses can trigger “distributed denial of service attack” (DDoS) protection as long as the ip range is not whitelisted on steams end

I know, but for someone wanting to trigger a DoS, triggering it from different IPs isn’t really an issue. There are a number of automated tools to do that. That is why I say that I don’t really understand what problem it would solve. Besides, cloud gaming is not new and throttling this kind of traffic would potentially just limit paying/legit clients from playing and, in my view, not really solve any big issue.

On a positive note, this seems to work again since the launcher was released. I still suspect some changes were made on the way mods are managed and downloaded by the client in preparation for today’s launcher release.

Thank you for your time and suggestions though. I truly appreciate it. (and your mods! I play with them everyday!)

for me, after the update on the 23rd, in my solo game 3 mods are being deleted from the text file, I don’t know which ones exactly, I use 48 mods and only 45 are appearing in the list and I’m having to put the file text with the list of mods manually in the Mods folder after starting the game from the launcher.

as I play on many servers and solo I have a copy of the mod list for each one, it was my “luck” because the mod that has the miniature vault is one that is not being loaded and is simply removed from the list when the launcher starts

and I was going to miss a lot of things

Hey, I found the solution by searching on the new launcher. You have to download the mods on the launcher by the workshop (Work on geforce) and then start your game normally and join the server and it works :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.