[BUG] After hotfix 2.3.1 I can't join servers with mods

Game mode: Online Private
Type of issue: Bug
Server type: Any
Region: Any

When joining a server with mods, mod mismatch is neither updating the mods nor downloading them when they are not installed. It launches, it displays the Status “Not installed” or “Needs update”, and when I press to download from the workshop, their status changes to “Queued” but nothing else happens.

I have tried this in different servers with mods, I always have the same issue.
I have tried to unsub by hand from the workshop and subscribing one by one - in this case, when I launch the game and enter the mod mismatch window, the status of the mod is “Needs update”, instead of “Not installed”.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Open the game.
  2. With no mods installed on the client side, join a server with mods.
  3. When mod mismatch launches, use the “Subscribe/Update all” button. The Status of the mods will change to “Queued”
  4. After that, nothing else happens. Mods don’t get downloaded.

Try to manually add the Mods. On game menu clock on Mods and add them manually, also set the Order right so you skip the mod mismatch window.

I only say this because i just logged in on a modded Server without problems, by default my Mod list is empty so i get the mod mismatch window everytime.

Hope it helps.

I know what you mean, but unfourtunately it is not possible in this case, because I play in Geforce NOW, which launches the game directly and I have no access to the filesystem.

I know I can still open steam overlay, go to the workshop, sub the mods and it should download them. Then I could go to the modlist on the game menu and do what you say. The problem with this is that when I sub them one by one on the workshop, they aren’t being downloaded.

The game supports mods, they even implemented the mod mismatch window to allow for updating the mods when joining. I have been using this method for over a year, downloading all of the mods every time I join the server, with no issues. Until the patch today.

Thank you for taking time and trying to help anyway. I appreciate it.

Fixed now in the new launcher.
More info: Bug to join a server after the patch 23/03/21 - #17 by Cytrek

  1. To the person reporting the bug… After updating a mod or downloading a missing mod while in game menus, you must next restart your game before the updates can complete.

  2. To Funcom’s “resolution” response…The new game launcher is not compatible with all systems that the game itself IS compatible on. The important links or buttons to start the game or do anything is completely off the screen. But the links to buy your other games are visible everywhere. But why would I buy another one of your games if I can’t play the one I have invested quite a bit of money and time on? And if this gets flagged as “off-topic”, I am not the one who changed the topic to “new launcher”. You are suggesting this customer to use something that is broke to fix something.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.