Major Bug: Updater Problem

Game mode: N/A
Type of issue: Bug | Performance | Other
Server type: N/A
Region: N/A
Mods?: [ Are mods installed: Yes ]
Edition: [ Select one: Steam ]


Bug Description:

The modlist updater when logging into a server basically does not work.
The orange progress bar of downloading the mod goes through and then the bar flickers between the “striped” state and the text “queued” in an endless loop.
It also randomly allows or will not allow the “join” button with no clear logic, when it pops up despite you having all the correct mods with correct versions otherwise.


Installed Mods:

If you answered ‘Yes’ to using mods, please list all your active mods. Otherwise, skip or delete this section.


Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Step 1 Install a mod on your server
  2. Step 2 Try to log in as player without having a mod
  3. Step 3 Choose update

I joined a new server a few days ago and downloaded all the mods via the mod mismatch without issues. Does it get stuck for you on a specific mod, does it work on another server, could it be that your connection is too slow and you get timed out?

It’s not limited to a specific mod and no, my connection is high speed cable.

Go unsubscribe to all the files, delete them from your workshop folder, then resub scribe. If that doesn’t work the mods on the server are out of date.

That’s not the problem. I do that every time I update mods.