Bug - Weapon Kit/Fitting does not work on Song of Iron Axe

Game mode: Online official
Type of issue: Bug
Server type: PVE
Region: Asia

Any weapon kit/fitting does not work on Song of Iron Axe. I tried the kit and fitting on any other crafted eldarium axe and it worked just fine.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Log into Isle of Siptah
  2. Reach level 3 to learn one handed weapon (warrior)
  3. Reach level 10 to learn iron tool and blacksmith’s bench
  4. Reach level 12 to learn tinker’s bench
  5. Reach level 30 to learn steel tool and improved blacksmith’s bench
  6. Reach level 37 to learn the elder construction in the leyshrine
  7. Reach level 50 to learn hardened steel tool and hardened steel axe
  8. Reach level 55 to learn star metal tool and grandmaster blacksmith’s bench
  9. Reach level 60 to learn epic one-handed weapon
  10. Grind elder vault to get lots of decaying eldarium to make as many as possible eldarium ingot and to get grandmaster weaponsmith recipe
  11. Craft an improved blacksmith’s bench
  12. Craft a T3 blacksmith’s bench
  13. Craft a delving bench
  14. Craft/repair hardened steel axes
  15. Delve lots of hardened steel axe to get song of iron axe recipe
  16. Craft song of iron axe, both normal and epic version
  17. Craft all kind of weapon kit and fitting
  18. Use all of the weapon kit and fitting on song of iron axe
  19. None of them work

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.