Cannot access any server, time out error

Game mode: All of them, Online
**Type of issue:**Cannot access any server, TIme out and Connection error message
Server type:All of them
Region: Any region

Ever since I bought the game I cannot access any server, be it official or not. I can play singleplayer just fine, reinstalled the game twice, verified it, nothing works. There must be something missing that I cannot see. Whenever I try to join any and all servers it just won’t let me, instead I get time out error. My internet is stable, there was no issue in downloading or installing the 3 times I did it.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

Not sure what you’d like me to write here, there’s really no way to explain it. I don’t know if it’s a bug or I’m missing files but I would like to know.

1 Like

Any firewalls working? Not an expert but maybe blocking a port or something. Also some isp providers block certain ports on their routers for some reason.


Also are you on wireless?
If so try to plug in a cable and check it then, because there are absolutely no reason for you to get a timeout that have to do with the game it self, it runs in sp, its the net/firewall/router that is youre problem.

Try to ping the servers you like, try it some times, if the answers are consistant post it here.

Firewall is working, not sure how to check if it is blocking something. I also am on cable.

You say its working and dont know how to check it?

Well, there are firewall in windows, in your antivirus probebly and in your router.

The router should be in default mode is you are not messing with it, so thats ok.

Windown firewall you can check easy and fast, just turn it off for a minute, forget the warning and try to connect to the gameserver.
Then turn off the antivirus firewall and test the same.

Turn them back on after the test, only a few minutes required to do that.

Also, have you tryed to ping any of the servers?
Because, if you get answer the firewall should be open.

Write down any server ip on the list, open cmd and write:

ping (ip)

Read the results and do it over a few times, the dos prompt will ping 4 times, but try it a few times more to se if its stable.
To try the ping command just run/cmd and write: ping or some other web adress you know, and then you can see the result you are looking for ande also see the different ping times of various web adresses, can be useful sometimes.

By saying firewall is working I meant it is on, I do know how to check it I just didn’t know how to check if it blocks the servers.

So I turned it off, same issue, can’t log in then turned it back on and it’s the same. Not sure how relevant it is, but yesterday I tried one without battle eye and it connected.

Anyways, back to your advice. I went to cmd, checked it with youtube at first and it worked but once I try a server IP it said “ping request could not find host”

Great, so it is probebly something with battle eye then.

Is it installed, is it activated when you start the game?

I ask because i get a confirmation box if i want it active or not, not quite sure how that software works, but definitively can be here the problem is.

I guess for some reason BE is not activated sence you can acess servers without it turned on?

Regarding the ping command, it may be so that some G-Portal servers are ping locked for various reasons so its not to relevant, as many do this.
Try this one, as it answers my command, and then try to connect to it, this is just for test purposes, as you can copy the ip and direct connect to it or search for it in-game.
Bothg are in EU region

7777 is the port and can be removed if no answer.

you can also do like this if you have the hostname.
remove the ports at the end if no reply.

When you get ping reply you have proven that you can acess the server, and thereby i would guess its something with battle eye and firewall etc are ok.

If you want to try and direct connect to the server in-game, remember to add the ports like above, or else it may not work.

In regards to this i feel confident that your problem has to do with battle eye.

1 Like

Did you try to reinstall battleye? (if it is present as Fingah says)
Check if batlleeye service is there etc.

Well then it is a problem with battle eye.

First I tried both the servers in cmd and I got a ping reply from them after removing the port. Also tried this with other servers and it’s clear I have access to them.

I also went and added to firewall some server IP’s and ports but nothing changed still.

I uninstalled battle eye, installed it again but there was no change whatsoever. How can I check if battle eye is performing correctly or installed correctly ?

Also I appreciate each and every answer, you guys are pretty fast. THank you.

Ok, one step closer then:)

Regarding battle eye there are some things reported, but if you have reinstalled it i guess this isnt the case.

Do you start the game from steam, and get the “with battle eye” or without battle eye question at startup?

As, if you start from a shortcut you will not get this question and it will run youre last configuration without asking you again.

One m ore thing, look if your antivirus is blocking battle eye or any services needed to run ce, that can happen.

I am sure many others can answer more about battle eye if they read this, google it and try some stuff is all i can say about that, as i havent had many problems with that my self.

Good luck

I’m slowly getting to the point of giving up. I have tried everything, even had a professional take a look at my router settings. Uninstalled my antivirus completely, made sure there’s nothing getting in the way.

And now, even though I didn’t change any settings, I can’t even connect to servers that don’t use battle eye…

I can’t wrap my head around this. There’s no online game I have ever played on this pc that gave me even the slightest problems. I know the game works, perfectly well in single player, but not online, and that is one thing that turns me off faster than my grandma in a tong.

There’s absolutely nothing on google that would help. Among the 10s of forums I found with people talking about it and getting no response or solution I found a website that gives a fix to install. Of course not for free, you have to buy a subscription to some sort of crap website. No, I didn’t sink that low but I’m close to giving in.

Do not. (ever)

did you uninstall battleye, (perhaps need to remove the folders too) and reinstall it.

Needed acces:
Valve, Steam

As fingah , i do not have any trouble with BE. Im not hot on it too, but lots do.

Need to have some assistance from BE experts, its not te be expected inhere it seems sofar, so need to go google and read alot im afraid.

I would go with “TImeout and Connection error message Battleye”

Among other things, I updated my modem firmware since battle eye was saying that could solve it. It didn’t.

Deleted battle eye completely and it still didn’t work. I went to an unofficial server that my friend owns, asked him to take down battle eye, and I still can’t log. On that or anywhere else it’s the same thing.

Whoever has any ideas keep them coming. I want to play this game and I’ll try anything, no matter how insignificant you think that idea might be.

One of my pleyer is experiencing the same.

We explore several solutions and nothing is working !

tried to :

  • empty the game cash and save = not working
  • uninstall/reinstall = not working

My thread here :[PC] Can't access to the selection list

  • check the firewall =not working
  • try with the mods/without the mods = not working

He stays blocked ont the main menu page and can 't acess the server list.

Not sure if it’s the same. I can go to the server list and I can see the servers, but I cannot connect to any of them.

could it be your internet provider blocking you, or some ports ? Some do so.

Or an other connection issue not directly related to the game itself ? Like your machine, and your steam handles the connection, or not.
I admit that you own a legit copy of CE bought through steam. Steam can be picky when it comes to veryfie copies, and ID’s.

Bought my copy when it was on sale last time, like a week ago or so. Bought through steam.

I checked the IP addresses for plenty servers in cmd and they all work.

Besides firewall and internet related things, the pc is not something I can say I really checked, mostly because I don’t know where to start. So again, I will be grateful for any tips and ideas.

This is hilarious. So update on my problem.

I kept trying to connect to a server with no luck, every day. Today like a miracle I managed to join my friend’s server, so obviously I checked if everything was in order so I can come here and let everyone know.

Now, of course I will log off the server and try to relog, just to check before posting anything on the server… IT"S NOT WORKING ANYMORE!!! xD So I’m beginning to think this is on the game’s end somehow. Battleye is fine, my internet is fine, my pc is fine, everything is fine since I was able to actually connect and play for a good amount of time.

Now I’m gonna throw myself at support again, even though I might get the usual “go to the forum cause we monitor it” message

I have had the same thing going on for a long time 3 tickets with funco no reply at all game use to work fine
good luck i gave up