Can't join any server at all!

Game mode: Official | Play Online

For the love of GOD!! Can’t even join any server! As soon as I try joining anything, it’ll lead me to the loading screen and then it’ll just kick me back to main menu page!!!

Please! I really wanna play the game! I tried verifying game integrity and update whatever I can with the game already. Is there any fix to this? Has anyone encountered this problem the same as mine?? Please help!

2 Likes

I have the same issue! (PC)

I just got the game installed but I’m unable to connect to any server at all. (Yes i have Battleye installed.) I can connect to single/coop but not any multiplayer server. Whenever I try to connect, 75% of the time after a few seconds of loading screen, I get thrown back into the starting menu of the game. About 25% of the time I do manage to get into the character creation but “lose connection” after a few seconds. I checked my firewall which is fine, reinstalled the game, … Nothing helps. There’s also nothing wrong with my general internet connection. Anyone who knows how to possibly fix this?

1 Like

I’ve had this issue ever since the climbing patch released in EA. My work around was use a completely different ISP (mobile hotspot).

Another thing that worked, as odd as it is, was launch the game, connect to server, and while I was on the loading screen I would tab out, disable my current network adapter and switch to the alternate one.

Example: Connect to server, tab out of loading screen, from current wireless connection (home wifi) I would disable that adapter and connect via wired connection (home ethernet.) I would tab back in, wait a minute or two and I would connect into the server no issues.

I’m having the exact problem that Elzetheon and PAKUNDO are having, just the same.
Any news?

Same mine sits there for a minute or two then kicks me back to the menu I had no issues at all before full release.

Hello @Funcom we are here and still waiting…

2 Likes

Same issue, funcom please help find a resolution for this problem. Good to know it’s not just me.

1 Like

Can you guys please check the Logfile and tell if there is any MSG about it?
Also please check the Battleeye log, maybe you get kicked because Battleeye was not reachable or something.

1 Like

I had the same issue but:

I formatted my HDD and reinstalled the game on the formatted HDD and now I can play :man_shrugging:

1 Like

I’m sorry to hear about the trouble you’re all having.

Players have contacted us in the past saying that, after trying to join a server, they get sent back to the main menu with no error messages.

Many of the players that contacted us were able to solve this issue by disabling their antivirus and firewall software. One of the more common AV programs we see causing this is AVG. Please try disabling any antivirus and firewall you have temporarily to determine if this is the cause of your particular issue.

If this doesn’t help, then contact us at help.funcom.com/ and create a “Tech” ticket for further assistance.

I tried both turning Anti Virus off and Firewall to no avail the day before last I did send in my logs to support so just waiting to hear back from that.

Wonder why it is doing this now though when everything was perfectly fine before release.

I did that, disabling Windows antivirus and firewall does not fix the problem… and i did send a ticket a couple of days ago… no answer at all yet.

I’m having a somewhat similar issue, where I can join a server. I can build a base, level up. but once I log off after the game time I spent doing all that. The next time i try to log into the same server, (Has happened on 5 servers so far) I always get a “Timed out from server.” issue and cannot log back in, no matter how often I try. So it seems whenever I finally make any progress in a game, the game server doesn’t let me log back in. Rather annoying to put all that time into a server just to get locked out basically.

Same problem here, even after turning off anti-virus and/or firewall, with a new info for you guys to check:

When i am at the infinite load screen, and hits the ESC key or any other key like iventory, etc, i can hear the sound of the menu opening/closing, so the game is running but the load screen is in front?

Still nothing… Just for let you know… 3 days later the tech support replyed my ticket and… even I described my problem with all details and told them that it kicks me to the main menu no matter what server i choose… for now… their “best” solution is that i have to try to connect to another server… for real :joy:

Well, it is impossible for me to log in using my rural ISP. They tell me their network runs behind a double nat and it’s up to the devs to enable play? They tried assigning a static IP for me to see if it’ll work but didnt. :frowning:

What’s wierd is that I can play any other online game just fine with my home ISP, it’s only conan exiles. Only thing I can do to play is connect with my cell phones hotspot and play with that… until I run out of data anyway.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.