"Cant connect to requested game"

Game mode: Online official | Online private
Type of issue: Bug
Server type: PvP | PvE-Conflict | PvE
Region: All

System: Win 10

So, I have a pretty massive issue, as I am unable to play online rn.
Whenever I join a game, I am either immediately thrown out, during the loading screen and get the error message “Failed to join requested game.” And other times, I do get on, but am thrown off after a few minutes, getting the same error message.
It does not matter, whether it is on a public server, or a modded private server, the issue is the same on both.
I can however play on empty servers, without any issue, both private modded and public ones. (Although I only played for about 5-10 min each for testing purposes, so the issue may still be there)
It does not matter, which account I use on steam, as each of my 3 accounts produces the same issue.

The issue occured first sunday 26th, and was not present two days earlier.

So far I tried
-The propsed fix of setting your max ping to 500
-deinstalling battleye, validating local files and running the game without battleeye to join our private server.
-Using different accounts on steam
-Reinstalling the game cleanly
-Running the game with Anti-Virus off
-Running the game with my PCs firewall off (I can not deactivate my routers firewall)

None of these things worked, I keep getting the same issue.
As I am an admin on a private server, this is quite the issue for me, as I cant do anything inside the game to help our players and the rest of the staff.

I also read about an infamous bug, that kicks some players, any time another player places any kind of placeable or building piece. And from what I gathered, it does seem to fit the issue, but from what I read, there is no client side fix, people have found.

But as it stands, there is no way to reproduce the bug, noone else of my team or players has the issue, who I talked to, and noone has heard of it either.

Please, I already sunk almost 20 hours into this issue, this week and I am about to rip my hair out.
Thank you for any help.

same iv tried everything and still wont let me play on any online servers but i can join a solo/co op game and invite friends but want to join an actual server

have you tried closing steam and starting it as administrator?

Narelle, yes I did

I actually found the issue on my computer. It seems, like a network tunneling program I had on was causing the issue. Namely Hamachi, which I had installed for LAN games in other games.

So, if you have the same issue, it may be worth looking into, if you have any programms like that, that could (why ever) mess up your connection.

(I did not test, if the problem still prevails, if I start hamachi during play now, so it may just be a coincidence still, but worth trying out, if you run it too, or any other programms that mess with local networks and internet through tunneling.)


iv tried everything and still nothing i havent downloaded anything for network tunneling ect please help

Usually this kind of errors are strictly related to connection @JonnyCarrman.

High ping (dued to Internet Provider problems) or software installed on your PC preventing connection to the server: firewalls, antivirus, or other software installed like the case of Kysali.

Even if you maybe do not relate the things, try to think anything changed since the game worked and now.

Or if it never worked it could be something you ever had installed on your computer (in that case be sure you do not have a firewall preventing the game to work properly)

Sadly it’s very difficult for us to help you just guessing what is preventing your client to etablish the connection to a server you see without errors in the server list, because we do not know all things installed on your PC that could interact with its connecting capability.

Hello @Kysali, welcome to the forums!

Apologies for not reaching out in time for this one, we’re happy to know that you’ve found a solution to your problem and we are thankful that you chose to share it with the community, as it will likely be helpful to other who might stumble upon the same issue!

@JonnyCarrman since your issue seems to have a different source, please create a new post that abides by our bug report guideline, and we’ll do our best to help you out, thank you for understanding!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.