Can't play multiplayer

Game mode: Online official | Online private]
Type of issue: [Misc | Connectivity]
Server type: [PvP | PvE-Conflict | PvE]
Region: [North America]

I’ve played this game for just over 100 hours during the last 3-4 weeks without issue. However, recently, I’ve been unable to join a multiplayer game. Nothing has changed on my end (except nvidia graphics driver update but that was a few days after my connectivity issues began). Whenever I try to play online and connect to a server I get a message “Failed to join requested game” and/or “Disconnected from server.” A couple of times I actually did make it into a game but I was disconnected shortly after. I usually play on a private server without battlEye but I’ve tried joining other servers some official and some private and the same issue occurs.

Here’s what I’ve tried without any luck so far.

  1. Verify integrity of game files on steam
  2. Install/Uninstall BattlEye
  3. Played the game in single-player mode
  4. Restart the game, restart my computer
  5. Uninstall and Reinstall the game on steam
  6. Reset my router and modem.

What do I do now?

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Click Play Online from main menu
  2. Choose a server
  3. Wait
  4. Try again

Hey there,

Does this issue happen when trying to play on an official server or also on private servers?

On both private servers and official servers.

1 Like

Just to rule out other possibilities, can you connect to other games on Steam normally? Is it only Conan Exiles that gives you this problem?

Yes, no other issues with the steam games or other multi-player games. Played Overwatch for a couple hours last night.

1 Like

Thanks for the information. We’ve received a few reports from other players recently with the same issue. We’ll look into it and try to figure out if there’s an issue on our end.

I uninstalled all mods the other day. Didn’t fix the issue.

Today, however, I was able to log-in and play for a bit. I don’t think anything has changed on my end.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.