Multiplayer Game Connection Issues

Game mode: [Enter game mode here: (Online public)]
Type of issue: [Enter one of the following: Bug (?)]
Server type: [Enter one of the following: PvP ]
Region: [North America]

Since first installing the game, I have only been able to play it four times, yet have made 20+ attempts to play with friends in two different servers.

At this point, I have tried the following:

  1. Deleting folders matching the game’s ID (440900) from my system and reinstalling and file checking the game.

  2. Verifying files, repeatedly.

  3. Unsubscribing from all the mods used in the servers I play in, repeatedly, and resubscribing to them.

  4. Pinging the servers I play in to ensure no errors (and there haven’t been any).

  5. Uninstalling and reinstalling BattlEye, just to see if that changes anything connection-wise.

  6. Flushing my DNS cache, as per a possible fix found in another player’s thread on the forums. This seemed to fix the matter, but only for a handful of minutes at most, each time I do it.

  7. Changing my ping on Steam from 5000 to 500. This has worked exactly once so far, three hours ago.

I have also checked the game’s requirements, and my computer’s hardware surpasses them (listing them below).

OS: Windows 10 64-bit
Processor: Intel Core i7-7700 8-core
Memory: 16 GB RAM
Graphics: Nvidia GeForce GTX 1060 (3 GB)
DirectX: Current (Unsure which version the latest is, off the top of my head)
Network: Ethernet (Unsure if broadband or whatever off the top of my head)
Storage: Plenty (game is currently installed already)

Any other help would be appreciated in resolving this issue.

Thank you in advance.

1 Like

Hey there @ThatDamnedBear

Welcome to our community.
We’ve gotten a similar report like this one recently. Just to make sure, and you’ve probably tried it already: can you connect to the server via the Steam friends list or via Direct Connect?

I think you checked also all anti-spy, anti-vire sorftware, firewalls and such ? Some may overdue and block.
Then maybe i would try to install the game/steam on a different directory to see. I know, all time consuming, and may not bring much…

Then also some internet provider may block in some part depending where you live. Hard to tell.
I see you did all the usual stuff without that. :man_shrugging:

Check with your ISP to make sure the ports aren’t blocked.

I moderate for another game, and just had a person over there using Vodaphone having a similar issue. Turns out they pushed an update to his modem that broke the ability to connect. Refreshing the modem with a new update resolved the issue.

1 Like

Ignasis - I may have tried those already, and forgotten that I did so. #lousymemoryproblems, lol

Vattende - I have checked to make sure that there is an exception for the game in my antivirus software (there is), I also tried turning my firewall off and back on (just once) to see if that affected anything. I would agree that this would be a problem, but I was able to connect with no problems to the servers 2-3 times -before- the issues started popping up.

SylenThunder - Similar to my answer to Vattende, if the ports were blocked I don’t think I’d have been able to join in the first place? But will double-check regardless.

I appreciate all the help either way. :slight_smile:

1 Like

The theory is that they weren’t block previously, but a remote firmware update caused them to be blocked.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.