Cannot place elevator

Game mode: Singleplayer
Type of issue: Bug
Server type: N/A
Hardware: Series X


Bug Description:

I cant place an elevator in a seemingly suitable spot for no apparent reason.

link to clip

As you can see, Ive elevators placed that drop down only 1 foundation in length, so that shouldnt be it, yet a few walls higher and it will let me? Ive tried without walls too, with finished walls, different/no foundations. I cant figure out whats actually causing it.

1 Like

This seems to be a fairly common issue, could be down to a few issues:

  1. Server lag
  2. Invisible terrain / barrier (sometimes looks can be deceiving)
  3. Doors / hatches (seriously elevators hate doors)

Hard to pin-point exactly a reason why from your video, but I don’t think the hatch frame helps.

Could be a support issue? Did you check the block at the bottom (where the lift would land) with the hammer tool and check its support? Might be something weird going on there, it happens sometimes.

Try re-logging (even a hard reboot, while annoying , wouldn’t hurt) and give it another attempt.

1 Like

Like @Crompox said the hatch was totally unnecessary! I remember having similar issues on ps4 especially on single player. Can you could try one thing please?
The wooden foundation you have on the bottom, build walls and leave the necessary doorframes ofcurce, build them around and then try to put the elevator, maybe this workaround will work, good luck @tobbiusness :grin:

Double check the stability of the ceiling where you want to place the elevator. Initially it won’t support it. Putting an elevator there is not as putting another ceiling. It takes more space. To place it I believe you would have to be able to place 2 ceilings with stability, not just one.
So, after you build that supporting wall, remove the ceiling and place it again. Sometimes stability transfer gets kind of wonky.
Then try to place the elevator without that hatch.

Thanks for replies guys. I tied without the doorframe and it worked. I’ve used hatchframes before and its worked fine so I didnt think they were the problem.

Stability may have also been a culprit at first.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.