Can't access Isle of Siptah, can't load into single-player at all

Game mode: Single-player
Type of issue: Performance / Crash / Other
Region: North America
Hardware: Xbox Series X

Bug Description:

Firstly, I paid for and downloaded the new Isle of Siptah DLC (Which I found strange that it was only 3gb, but I digress) and theres no access point for the Isle of Siptah for single player? Nothing whatsoever on the menu, so confused I figured I’d load up single-player as normal and maybe there was a way to play it once in the game… well, not that it could see? So firstly, is the Isle of Siptah only accessible online? Can you not go there or play it on single-player??

So then secondly, I restarted my game thing it maybe didn’t load up properly and not only did I have to try to boot the game up 3 times but once I finally got it going again, I can no longer load into single-player. Every time I laugh single player it almost loads fully then freezes. Please please PLEASE don’t tell me the whole game is broken again!?

Someone please help on both matters.


1 Like

Have you tried starting a new single-player game? As IoS has a separate save from EL, you can switch back and forth as you please on start but you will 1st need to create the IoS save.


I did and it worked!!! Thank you!!!
Though I am still having issues with the loading screen freezing at the very end upon trying to load my single player in the exiled lands

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.