Can't connect to the dedicated server I'm hosting

Game mode: Online private
Type of issue: Misc
Server type: idk
Region: South America

I set the dedicated server with the app and I’m trying to join it with the same machine that is hosting. I changed the game port to 7779, the RAW UDP port went to 7780 and the Steam Query Port to 27045.
Tried both with Multihome checked and unchecked.
Light are always green.
Game version is compatible(I’m using DLC’s tho).
No Mods.
Saw a thread where a guy says he connected but starting the game first. Tried that too and it didnt work. Didnt work either starting the server first to avoid those error messages.
My server doesnt show up on the list but my friends can direct connect to it. I, however can’t, as I keep getting a message saying “The conection expired! It wasn’t possible to find the server.” (I was also getting a similar bug trying to join my friends coop, saying I lost the connection to the host. I had to try multiple times to succesfully join his game and I tried multiple times to join on mine too, I don’t know if these bugs are related or if It’s a bug regarding server/playing on same computer limitations).
I also tried multiple ports values for Steam Query Port.
Now I’m stuck and don’t know what to do.

Edit: I found a solution. I was trying to join the server using the external IP (the one my friends use to join). I succesfully joined using my own IP instead.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Set up dedicated server with the app
  2. Try to join the server on the same machine the server is being hosted
  3. You can try changing the ports and the error remains the same.

Don’t feel bad, I’m a sys admin for a living and I wasn’t able to get playing and hosting from the same machine working either. :sweat_smile: You might do well to ask about this in the pinned topic for the server launcher, though from some of the posts I’ve seen by it’s author, there’s no guarantee that this 100% achievable:

This post also has some helpful info:

Indeed: I’ve managed to help some people to do it, I’ve managed to do it on my home machine, but I’ve never managed to do it on my main work machine. The one where I develop the actual tool.

There are so many things that can go wrong, between the network drivers, the firewalls, the router, …


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.