I TRIED EVERYTHING but I can't get into my own Dedicated Server no matter what I do

This issue happened this morning where I am unable to join MY OWN DEDICATED SERVER along with 1 friend, meanwhile I have 2 other friends that’s able to join into the server just fine with no issue and I am having an impossibly hard time trying to figure this out.
Keep in mind that the server had a few mods but this joining issue wasn’t a thing for a week until recently.

I tried:
Uninstalling/Reinstalling Battle Eye
Playing with no Battle Eye
Redownloading all my Mods
Reinstall the WHOLE GAME
Cleared Download Cache
Opened All the Firewall Ports related to the game
Changed the Ports
Unplugged/Replugged my Router
Made a fresh server

Nothing, the server doesn’t have vac or battle eye enabled or anything that should prevent me from going in and there is not a SINGLE SOLUTION. I’m desperate for any solution at this point, I spent a about 2 whole days trying to figure this out. Any suggestions?

if it’s a private server then you have to contact gportal and have them check the server in case something is wrong as funcom can’t access that check with them then get back to us on results then we can narrow it down some

It’s a dedicated server running from my machine.

Is it the same pc you are playing on or a different one?

If it is the same PC: Can't connect to the dedicated server I'm hosting & Can't join local dedicated server unless I start the game first
If it is another PC in the same local network, use the local IP to connect to your server instead of the external one.

ill see what I can do.

1 Like

Let us know if any of this works.

Hey @DragoXD

Welcome to our community.
We’d suggest taking a look at our Dedicated server tool thread here, where there’s an extensive FAQ of the most common issues and questions. If after reading it you can’t troubleshoot this issue, we’d also recommend sending your question there since chances are you will get an answer from other players who’ve experienced the same problem or know how to troubleshoot it.


It didn’t work, the issue is still Authentication Error.
At one point there was an issue with the password not working so I vertified the server, and it went back to Authentication Error.

I’m able to join when no one else is on the server, but I shouldn’t have to ask my friends to leave the server whenever I need to join.

are u running ur server using the Dedicated Server Launcher or by the option to host dedicated server?

ill strong suggest to use the Server Launcher, since it provides full configuration of server and setting, and has nothing to do with ur game launch

I am using the Dedicated Server Launcher.

So I have a very courios question do you have windows 10 they did a update 1 year ago that stopped my games from launching and hinder others I found out it was a sucurity ( fighting autocorrect a guard team you hire that word for them sorry) but it would not allow it to work as it considered it a threat last week they did another one so it may be blocking it or if you receive another update for what you have it also could be blocking it thought I hope not for mine was uninstall was not able for the pc I had called them and had to do custom installation and worked after that the tech disabled the update system cause I also used it for work and also that was blocked after so time the system would update itself after some time for it was safe and would not do that as they altered it for comparably and thus I was go to go so if you can see update it might be blocking it and you don’t relish it hope that helps

I’m not 100% sure, but I think what fixed this stressful issue of mine was the result in loading into singleplayer and joining into the server afterwards. Might be possibly that it takes too long to get into the server that it would cause a network error of sorts but letting all the assets load in and then joining the server would only need to load the networking stuff? If that’s the case then I’d like to apologies that this issue that caused me days of stress had just a simple “Load in singleplayer” solution.


Thanks for posting the solution.
It’s very much not obvious, and it should give a proper error, or better, it should not happen at all.

Lol that also solves getting into offical and private too but now i know it works for that too its also what they say too

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.