Cant join local dedicated server while hosting on separate machine

Game mode: online private
Type of issue: cant join server
Server type: pve
Region: na

I’ve downloaded the dedicated server app on my laptop thats connected to ethernet, set up the server and installed. I have opened up the ports 7777, 27015, 27016 for both tcp and udp, tested port accessibility and got all greens, while also running port checker software as well. ran the server ( multiple times with different settings ex. with and without multihome ) and tried to join the game on my desktop, in multiple various ways. It wont let me join, it just loads for a long time and says connection error or something of the sort and brings me back to the main menu. I googled my issue, read multiple threads and such. some people have suggested multihome, changing server ports, but I am running on 2 machines. How does this work? What do I do if im hosting on one machine and joining on another? I can include pictures and stuff if needed. I’ve been at this for about 3 hours and am clueless about what to do. My friends can all join my server but I cant.

Couple of questions:

  • Friends joining, are they connecting to your external IP, and routing through your firewall? Or are they on your LAN?
  • Have you tried connecting to the server (laptop) with its internal IP, or are you trying to connect to the external IP also?

my friends are connecting through my external ip, they are not lan and I have tried connected to my laptop through both internal and external ip on my desktop, with and without port numbers as well and to no avail on my end.

@Toolguy I am not sure whether you are reading these sections but are you able to offer any assistance to op?

@FroboSama Conan Exiles Dedicated Server Launcher (Official Version: 1.0.45 / Beta: 1.0.46) There is this super detailed thread here with a lot of questions and answers already given. Toolguy is also actively providing support where he could. You may be able to find something helpful in there.


Edit - I should follow my own advice, and read what @Narelle posted first :stuck_out_tongue: The guy she links has a similar problem to you with a potential solution…

Here’s my config, in case that helps. All my connections are currently over a LAN, so no external firewall setup in place.

In the Windows firewall on the host I have the ports open (7777, 7778, 27015, 25575) in the “inbound” policy for TCP and UDP. Less restrictive than I need, but it is only currentlly accessible “locally” or I would be more precise.

So the problem arises more than likely because you’re on a NAT* local network. Your friends can connect externally, because you’ve opened the pinholes and allowed players to connect via hitting the EXTERNAL IP Address. This is the IP address of your house, basically, and internet providers work very hard to keep their traffic moving properly. Sending out a request, through the internet, to come back into your External IP Address is called a loopback. This is something ISPs generally prohibit, even via ping.

In your hybrid situation, you have an External address that works fine. You need to look for the LOCAL, or NAT address of the laptop. In @Broc’s example, this is “ on Intel…”

Using Steam, click View -> Servers. Sometimes you can find a Local asset/server by clicking the LAN tab. If this doesn’t work, Click Favorites, then Add A Server. Type in the Local IP address you found in your server console, add a colon, and the Steam Query Port. Click Find games at this address… Then add it to Favorites.

Good luck, feel free to ask follow-ups.

* Network Address Translation: you are given a local, differently-classed IP address for use among your network. In this way your external IP address can be operated by multiple clients, within a separately firewalled and “protected” zone. Addresses in NAT are similar to, and the like.


Ok I finally managed to connect to the server, I disabled windows firewall and norton firewall on my laptop and was able to connect by direct connect with the laptops ip not external without the port, with the port did not work. The steam > view > server > lan shown the server but i was not able to connect and connecting via the online lobby list also does not work. But I think it’s safe to assume that it was the firewall that prevented it ? idk but thank god finally i can enjoy the game. Debugging sucks :p. thanks yalls for the tips and info.


Glad you managed to solve the problem.
On the Dedicated Server Launcher top post there’s a list of things that can cause issues:

If despite everything you still cannot get through, make sure that you do not have a firewall somewhere configured to block everything.

Generally when I try to track this type of problem:

  • I make sure that my machine is fully updated
  • Than no other software than what I need is running
  • I disable the firewall
  • I tweak the network issues until it works
  • If it works, I enable the firewall again
  • If it stops working then I investigate firewall rules (inbout/outbound rules, ports, etc…)

Firewalls are useful, but when diagnosing, the less moving parts, the better chances you find the issue fast.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.