Issues with joining my own server

I have setup my own server which, in most aspects, works great. Everyone I provide the password to is able to join and play… except me. I am utilizing the latest version of the Conan Exiles Dedicated Server app and have updated the Ports from 7777 and 7778 to 7779 and 7780. Additionally, I have updated the steam port 27015 to 27016. I have also selected my IP address and checked the “Multihome” setup checkbox. This server sits on a dedicated desktop in my house and I’m attempting to access the server from a laptop (on the same wireless connection). I’m sure it has to be something simple but can anyone help me out here? I can provide any additional info needed, thank you!

Why did you check multihome? I think that feature is only required when you run 2 or more server. Try disabling that.

I unchecked that option and removed the IP address associated with it. Still no luck at this point. I can see the server on my list but when I join, nothing. I’ve been sitting at the join screen for around 2 minutes now (everyone else got in almost immediately). Any other ideas?

You tried connecting by clicking the name in the server list? If so,
try the direct connect option and fill in the ip:port

Direct connect times out. Really confused there because other people are able to join. I just verified with a friend.

Ok then maybe your windows firewall is blocking traffic to those ports.

Check windows firewall with advanced security. Create new rules for inbound/outbound traffic on the ports you configured.

You could also try to use the internal IP of your server if it is on the same network.