Can't join local dedicated server unless I start the game first

Game mode: Online private
Issue: Can’t connect
Server type: PVE
Region: Europe

Whenever I start up my home-based dedicated server (On the same pc with which I play the game), I can’t join my own server. This ends up with the notification “Invalid password”. Then, if I remove the password, I get some error about a uniqueID. Whenever this happens, the in-game serverlists also will not show even one server. It only loads servers when my own dedicated server isn’t running.

However, I have now found it this only happens if I start the server first. When I do, it seems to block port 7777 or something… I don’t know too much about it tho.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Set up dedicated server (Without the app, which doesn’t work at all for me)
  2. Start dedicated server (BEFORE starting the game)
  3. Start game
  4. Try to join own server through
  5. See error.

How to fix it for now:

  1. Start the game FIRST
  2. Go to the online lobby
  3. Start the server
  4. Join without issue
1 Like

Hey @NoobishPro

Welcome to our community.
Just in case, have you taken a look at our Common Technical issues thread and the Dedicated Server App thread? In there we cover a known issue when hosting a dedicated server on the same computer.
Thanks for your feedback.

Hello Ignasis,

If you had read my problem, you would’ve probably found out that this specific problem is not mentioned anywhere on the forums. Hence the new topic.

I have been googling issues surrounding this game for days now and a lot of those results get me back onto this forum and the threads you’ve mentioned. They have, however, nothing to do with my post.

1 Like

hey, @NoobishPro. First, looks like @Ignasi C&P same link to both suggested threads.

I believe the second should be:
Conan Exiles Dedicated Server Launcher (Official Version: 1.0.39 / Beta: 1.0.40)

Also, in here is probably the solution to your problem: Both steam and default server setting would use querry port 27015 and port 7777. You need to change ports on your server and problem should be solved.

Also @Ignasi, there is a small typo in that quote (2715 should be 27015 I guess)

Please report back if that helps.

1 Like

Hello Meo,

I’ll see if that solves my problem. I am, however, NOT running multiple servers. Only the one. I’m also not using the app. I’ll get back to you later when I change the ports of the server.

Problem with ports is same if you use 2x server or server + client (steam).
Also, did not try it much, but as I understand, this app is just something that works like a GUI, sitting on original SteamCMD server (someone correct me if I am wrong)

@Hugo, connecting to another thread

@NoobishPro, just out of curiosity, I just tried what I suggested:
I set the server (using the app) set ports to 7779 and 27019
as usuall there were those errors on server start.
After that I started the game on same computer and joined via direct connect without problem.
Then I joined that server with another account on different computer, same network.

to note: not much experience with dedicated server, I just sometimes play around with it to see what is possible and… if I can do it in the first place :face_with_monocle:

PS: This app REALLY makes things easier! Awesome work!

Hello Meo,

Still haven’t tried it. I think it’ll be tomorrow then…

But the steamdll error on-join wasn’t an issue for me until the latest update.

I did solve a lot of problems by going the -nosteam route, but in that scenario I lost my own character which was a no-go as I switched from co-op to a dedicated server after dozens of hours of playing =)

Hey there Meo,

Strangely enough, changing the ports to 7778 and 27016 did indeed fix the steamdll errors on join!

I’ll still have to get back on the starting game first > then server thing, though.

Can confirm now, it indeed also fixed the boot-order issue. It would seem that running the dedicated server would block the ports for the game.

If this is really the case, the devs really screwed the pooch

Hey @NoobishPro, I am glad you got things running :smiley::+1:

As for the “pooch”… that was “present” way before Steam, or Funcom or Conan.
Simply put: on one computer, only one app at the time can use a certain port. While using it its blocked for every other app on the computer.

There are simple reasons why 7777 and 27015 are set as default on conan server (briefly explained in the post I linked above).
In same breath, there are also very simple ways to modify those ports, as you found out.
Modify some text files, create a short .bat that would take care of that or now, with the app, make it happen literally with 3 clicks.

Anyways, now you again in control! Off you go to claim the Exiled Lands! :grin::point_right:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.