Can't Craft Building Pieces from Action Bar

Game mode: Online private | Single-player
Type of issue: Bug
Server type: PvE
Region: NA
Mods?: No
Edition: Steam

Bug Description:

Previously you used to be able to put building pieces like walls for foundations in your action bar, place the building piece, then press that action bar key to craft another building piece in that slot if you had the resources in your inventory to do so. That no longer seems to work and building pieces can only be crafted in the inventory window. This does not happen for other items such as bed rolls which can be crafted in both the inventory and on an action bar slot. The ability to quickly craft just one or two pieces quickly was very nice and useful.

Steps to Reproduce:

1. Craft in your inventory or admin panel add a building piece such as a foundation.
2. Add it to a slot on your action bar.
3. Place the building piece.
4. Press the same key for that building piece’s action bar slot and notice how you cannot craft a new one from the action bar when you used to be able to. A new one can only be crafted in the inventory window.

That still works for me. I haven’t had any problems. I doubt which map you are playing on would make a difference but which is it, Siptah or Exiled Lands.

Really? Strange. It doesn’t work for my friend and I on our dedicated server, and I tried in single-player too. Both on Exiled Lands. Are you playing on that map too?

I am on Exiled lands right now. Just got done with Siptah not to long ago and as far as I remember there was no problem with that.

Well I booted up today and now it’s working properly in single-player and on my private server. I don’t think I was doing anything wrong on my end but I’m not going to look a gift horse in the mouth haha. Sorry for wasting your time.

You didn’t waste my time, no worries man. Glad it all worked out for ya. :slightly_smiling_face:

1 Like

It only works (worked?) if there is no pieces left of said building pieces, no?

There should be a faint pic of the building piece in the quick bar. If it’s just an empty slot than it will not work.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.